Realplayer plugin causes clicking "Application" tab in preferences hangs in 64-bit mode

RESOLVED WORKSFORME

Status

()

Firefox
Preferences
--
critical
RESOLVED WORKSFORME
7 years ago
5 years ago

People

(Reporter: Deng Xiyue, Unassigned)

Tracking

Trunk
x86_64
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b7) Gecko/20100101 Firefox/4.0b7
Build Identifier: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b7) Gecko/20100101 Firefox/4.0b7

When trying to click application tab in the preferences dialog, Firefox just freezes, and the CPU usage went up to max. I waited for a couple of minutes, and nothing changes, so I have to kill Firefox.


Reproducible: Always

Steps to Reproduce:
1. Open preferences dialog through menu
2. Click Applications tab.

Actual Results:  
Firefox freezes.


Please note that create a new profile DOESN'T make the problem disappear.

Also, this only happens on my MacBook Pro (Mac OS X 10.6). Can't reproduce on another Windows 7 machine.
(Reporter)

Updated

7 years ago
Severity: major → critical
(Reporter)

Comment 1

7 years ago
This problem is still reproducible on beta 8.
(Reporter)

Comment 2

7 years ago
Still reproducible on beta 9. Here's the backtrace of the freeze:

$ gdb --pid=66175
GNU gdb 6.3.50-20050815 (Apple version gdb-1510) (Wed Sep 22 02:45:02 UTC 2010)
Copyright 2004 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "x86_64-apple-darwin".
/Users/dxy/66175: No such file or directory
Attaching to process 66175.
Reading symbols for shared libraries . done
Reading symbols for shared libraries .......................................................................................................................................... done
0x00007fffffe00279 in __spin_lock ()
(gdb) bt
#0  0x00007fffffe00279 in __spin_lock ()
#1  0x00007fff854c24da in glueReleaseInfo ()
#2  0x00007fff854b7f6c in ImageProviderReleaseInfoCallback ()
#3  0x00007fff889abc6c in image_provider_finalize ()
#4  0x00007fff8901da73 in _CFRelease ()
#5  0x00007fff88987fbd in image_finalize ()
#6  0x00007fff8901da73 in _CFRelease ()
#7  0x00007fff8903ffa3 in __CFArrayReleaseValues ()
#8  0x00007fff8901da73 in _CFRelease ()
#9  0x00007fff877e0b3c in _ISReleaseStorageRef ()
#10 0x00007fff89034fb0 in __CFDataDeallocate ()
#11 0x00007fff8901da73 in _CFRelease ()
#12 0x00007fff854b81e8 in _CGImageReadFinalize ()
#13 0x00007fff8901da73 in _CFRelease ()
#14 0x00007fff854b2e93 in _CGImageReadSessionFinalize ()
#15 0x00007fff8901da73 in _CFRelease ()
#16 0x00007fff89022153 in __CFDictionaryCallback ()
#17 0x00007fff89034d01 in __CFBasicHashDrain ()
#18 0x00007fff8901da73 in _CFRelease ()
#19 0x00007fff8558d559 in _cg_JP2TearDownDecompressor ()
#20 0x00007fff8550b9bb in JP2ReleaseInfoCallback ()
#21 0x00007fff854c24f6 in glueReleaseInfo ()
#22 0x00007fff854b7f6c in ImageProviderReleaseInfoCallback ()
#23 0x00007fff889abc6c in image_provider_finalize ()
#24 0x00007fff8901da73 in _CFRelease ()
#25 0x00007fff88987fbd in image_finalize ()
#26 0x00007fff8901da73 in _CFRelease ()
#27 0x00007fff890471e6 in _CFAutoreleasePoolPop ()
#28 0x00007fff816b604b in -[NSAutoreleasePool release] ()
(gdb)
(Reporter)

Comment 3

7 years ago
This also happens on latest Minefield downloaded one hour ago.
(Reporter)

Updated

7 years ago
Version: unspecified → Trunk
(Reporter)

Comment 4

7 years ago
jmlane on irc reported that this problem doesn't affect his/her 10.5.8 (32-bit). So this might be 64-bit specific. The affected machine of my friend is also running 10.6.6 (64-bit).
(Reporter)

Comment 5

7 years ago
Just found out that, this won't happen when Minefield is run in 32-bit mode. So it is 64-bit related.
(Reporter)

Updated

7 years ago
Summary: Freezes when application tab in preferences dialog is pressed → Clicking "Application" tab in preferences hangs in 64-bit mode
(Reporter)

Comment 6

7 years ago
After some tweak and help from juanb and ashughes from IRC, I may have found the cause: After removing the realplayer plugin from /Library/Internet Plug-Ins, and remove the program that handles local real format files (mplayerx in my case), Minefield in 64-bit doesn't hang any more. Reinstalling the local program (mplayerx) again also doesn't cause hanging any more.

One thing to note here: merely remove the realplayer plugin doesn't fix the problem. It stops hanging after removing or reinstalling the local program than handles real formats. So it is hard to tell which actually causes the problem, especially now the symptom can't be reproduced for the moment.

HTH.
Summary: Clicking "Application" tab in preferences hangs in 64-bit mode → Realplayer plugin causes clicking "Application" tab in preferences hangs in 64-bit mode
I guess it's ok to mar this wfm now
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.