The jetpack-core package should be renamed to api-utils to better reflect its purpose.
We should do this as one of the last changes we make before shipping the first 1.0b1 release candidate to avoid rotting a bunch of blocker patches.
Since this should be done right before spinning the RC, which I'll be doing, I'll take this on. Note that this is much more than simply renaming the directory, as there are a bunch of (primarily documentation and test) files that reference "jetpack-core" , and there's even a second directory with that name at python-lib/cuddlefish/tests/static-files/packages/jetpack-core.
Assignee: nobody → myk
Status: NEW → ASSIGNED
Created attachment 494223 [details] pull request #67v1: makes changes Here's a set of commits that makes the necessary changes.
This looks great! It's also the first time in a while for me that we're running with all tests passing on ff4.0b7 and the latest nightly. Woo! Pushed: https://github.com/mozilla/addon-sdk/commit/0727c3a1c3b7da6f64234042f211786ee5b28841
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.