dirs with ending slash in addFile() hang the progress dlog

RESOLVED WONTFIX

Status

Core Graveyard
Installer: XPInstall Engine
P3
normal
RESOLVED WONTFIX
17 years ago
2 years ago

People

(Reporter: David Epstein, Assigned: dveditz)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
1. Go to http://jimbob/trigger3.html
2. Enter either of these in the url field:
a. http://jimbob/jars/f_addf_fileindir_source1.xpi (this passes 'dir/' into the 
jarSrc (3rd) param of addFile.
b. http://jimbob/jars/f_addf_fileindir_target2.xpi (this passes 'dir/' into the 
target (5th) param of addFile.
3. Press Trigger. Then OK the confirm dlog.
Result: Progress dlog hangs. On Windows 98, get "an unknown error has occurred 
(804b0003) in the status bar area.
Expected: No hang. Progress dlog completes.

Comment 1

17 years ago
What's happening is an infinite loop in nsInstallFile's constructor.  A trailing
slash is actually an invalid parameter so it should error out.  I've got a fix
for this that will be posted in the bug for long filenames (10147) since that
bug is being fixed at the same time and in the same code.
(Reporter)

Comment 2

17 years ago
*** Bug 61310 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

16 years ago
Status: NEW → ASSIGNED

Comment 3

16 years ago
bug 10147 was verified fixed on March 9th. Was this fixed along with it?
(Assignee)

Comment 4

10 years ago
The xpinstall script engine has been removed from the trunk, bugs in it are obsolete.
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WONTFIX
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.