Unable to close the preference dialog after selecting the smart browsing

VERIFIED DUPLICATE of bug 62903

Status

P3
normal
VERIFIED DUPLICATE of bug 62903
18 years ago
14 years ago

People

(Reporter: pmac, Assigned: matt)

Tracking

({helpwanted})

Trunk
x86
Windows 98
helpwanted

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: dup of 62903)

(Reporter)

Description

18 years ago
Platform: Mac (2000-11-28-08-Mtrunk); Windows 98 (2000-11-28-06Mtrunk)
I haven't tried on linux yet since my linux machine does not work.

Steps to reproduce:

1. Launch Netscape 6
2. Type this url: http://www.yahoo.com
3. Go to Edit/Preferences/Smart Browsing and click on "Enable internet keywords"
   and "More Information..."
NOTE: Unable to close the preference dialog. The workaround is to close
the browser first and then close the preference dialog. It works ok
on the branch build 2000-11-08-00-MN6.
(Reporter)

Updated

18 years ago
Keywords: vtrunk
(Reporter)

Comment 1

18 years ago
remove the keywords "vtrunk". accidently enter mistake.
Keywords: vtrunk

Updated

18 years ago
Blocks: 40891

Comment 2

18 years ago
Wait, I think I was too premature in marking the dependency.  This works fine 
for me, but in order to close the prefs window, you need to close the new 
browser window first, because the new window is modal (since it's launched from 
a modal window).  Does it work after you close the new browser window?
No longer blocks: 40891
yeah, methinks this is expected behavior, patty... if the workaround works, then
this should prolly be marked invalid...
(Reporter)

Comment 4

18 years ago
Blake, yes, it works ok after closing the new browser window. The reason I write
this bug up because the behavior is different from the branch build dated 
(2000-11-08-00-MN6). For that build (2000-11-08-00-MN6), you can close the 
preference dialog box without closing the new browser window.

Comment 5

18 years ago
This is happening for me when I am attempting to edit my search prefs in Smart 
Browsing.

This is *not* in any way expected behaviour and I can not understand how one 
could claim that. This is a very annoying bug that needs to be fixed, it 
prevents me from using the Search feature.

Adding helpwanted and mozilla0.9 keywords.
Keywords: helpwanted, mozilla0.9
when i said expected behavior above, i wasn't implying that it was the ideal
behavior. :) iirc, this might be due to how mozilla handles modality --might not
be citing the right bugs here, but perhaps bug 65521 and bug 19221 could shed
more light. jrgm, danm, thoughts?

Comment 7

18 years ago
See bug 62903 (and this bug and that bug are duplicates; pick one, although
bug 62903 notes a nasty consequence of opening a full browser window as a 
modal). 

I agree that this is not the best use of modal windows, but it is "by design" 
(e.g., for the example in this bug report, the modal windows are behaving 
correctly).
Whiteboard: dup of 62903
thx, jrgm. dupping...

*** This bug has been marked as a duplicate of 62903 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 9

18 years ago
verified.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.