Closed Bug 613562 Opened 9 years ago Closed 9 years ago

VKB will stay open in portrait mode when going to the preference panel

Categories

(Firefox for Android Graveyard :: General, defect)

ARM
Android
defect
Not set

Tracking

(fennec2.0b3+)

VERIFIED FIXED
Tracking Status
fennec 2.0b3+ ---

People

(Reporter: nhirata, Assigned: vingtetun)

References

Details

(Whiteboard: [vkb])

Attachments

(1 file)

Mozilla/5.0 (Android; Linux armv71; rv2.0b8pre) Gecko/20101119 Firefox/4.0b8pre Fennec/4.0b3pre

1. close the hardware keyboard
2. place device in portrait mode
3. go to google.com
4. click in the text field
5. open the control side panel
6. click on the gears to bring up the preferences panel

Expected: VKB will disappear
Actual: VKB stays open
Whiteboard: [vkb]
tracking-fennec: --- → ?
Sounds like we need to Deactivate the browser when the broadcaster changes
Assignee: nobody → 21
tracking-fennec: ? → 2.0b4+
Duplicate of this bug: 613635
Attached patch Patch + testsSplinter Review
Regression from bug 589337. The patch fix the bug and I've added a few tests for those type of bugs
Attachment #492961 - Flags: review?(mark.finkle)
Attachment #492961 - Flags: review?(mark.finkle) → review+
Let's get this in b3 since it is a regression
tracking-fennec: 2.0b4+ → 2.0b3+
http://hg.mozilla.org/mobile-browser/rev/000351e28041
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Please check bug 613635 when regressing this bug.
verified FIXED on build:
Mozilla/5.0 (Android; Linux armv71; rv:2.0b8pre) Gecko/20101129 Namoroka/4.0b8pre Fennec/4.0b3pre
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.