Lost function in 'bookmark this page' dialogue box with upgrade to firefox 3.6.12, cannot highlight, cut, copy, or paste within the 'name' box, cannot edit within the name box at all until AFTER selecting bookmark folder to use.

RESOLVED INVALID

Status

()

Firefox
Bookmarks & History
RESOLVED INVALID
8 years ago
7 years ago

People

(Reporter: noneyabeeswx, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.2.12) Gecko/20101026 Firefox/3.6.12
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.2.12) Gecko/20101026 Firefox/3.6.12

I just upgraded to firefox 3.6.12.  Now, when I select "bookmark this page" I cannot do anything with the entry in the "name" box until after I've selected the folder I want the bookmark to be in - can't change the name at all, can't add a name, nothing.  

If I don't change the folder from the default "bookmark menu" folder, I cannot change the name at all.  Once I've selected a folder, it will allow me to put the cursor into the name box.  Where ever I first put it is, however, where it will remain, I can't move it using the mouse after first putting it there.  At that point, I still can't highlight anything there or cut, or copy - all I can do is use arrow keys to move over text I want to remain to try to get my cursor where I need it, or use delete or fn-delete to get rid of what is there that I don't want character by character, and then enter the name I want it to be.  And/or I can use paste to put text in, at the spot the cursor happens to be at.  This is very frustrating.

Reproducible: Always

Steps to Reproduce:
1.select bookmark this page
2.try to edit the name of the bookmark to be created
3.
Actual Results:  
As described in the details section.

Expected Results:  
It should function as it did in older versions of firefox - you've lost functionality rather than gaining it with this upgrade.  It should allow me, from the minute I get into the "bookmark this page" dialogue box, to edit the name of the bookmark being created.  It should at all times allow me to highlight any portion of the bookmark name, and use the cut or copy commands.  I should not have to change the folder to be able to edit the name. 

I'm using the default theme.
Have you tried safe mode? http://support.mozilla.com/kb/Safe+Mode

Could be an incompatible add-on is causing your trouble.

Comment 2

8 years ago
I see the same thing on version 3.6.13 on a Solaris 10 SPARC system.  And yes, the problem goes away when running in safe mode.  So far, I have been unable to determine which add-on or config setting may be responsible.  If anyone finds out what causes this, please post the answer here.  Thanks.
invalid since due to add-on.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.