If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Firefox/4.0b8pre 64-bit crash [@ mozcrt19.dll@0x4ba7 ] [@ extent_tree_ad_insert ]

RESOLVED DUPLICATE of bug 625753

Status

()

Core
General
--
critical
RESOLVED DUPLICATE of bug 625753
7 years ago
6 years ago

People

(Reporter: Scoobidiver (away), Unassigned)

Tracking

({crash, topcrash})

Trunk
x86_64
Windows 7
crash, topcrash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

7 years ago
It is a residual crash signature in 64-bit trunk builds.
It is #1 top crasher in today's build.

Comments say:
"I was running the Dromaeo Benchmark suite and crashed"
"60-70+ tabs makes browser unstable"
"Ram usage or flash-related crash"

Signature	mozcrt19.dll@0x4ba7
UUID	fc345e47-3a45-45af-bf07-1c8302101119
Time 	2010-11-19 19:11:20.366323
Uptime	21759
Last Crash	291078 seconds (3.4 days) before submission
Install Age	28537 seconds (7.9 hours) since version was first installed.
Product	Firefox
Version	4.0b8pre
Build ID	20101119054519
Branch	2.0
OS	Windows NT
OS Version	6.1.7600
CPU	amd64
CPU Info	family 6 model 30 stepping 5
Crash Reason	EXCEPTION_ACCESS_VIOLATION_READ
Crash Address	0x18
App Notes 	AdapterVendorID: 1002, AdapterDeviceID: 68c0

Frame 	Module 	Signature [Expand] 	Source
0 	mozcrt19.dll 	mozcrt19.dll@0x4ba7 	
1 	mozcrt19.dll 	mozcrt19.dll@0x9856 	
2 	mozcrt19.dll 	mozcrt19.dll@0xa8a27 	
3 	mozcrt19.dll 	mozcrt19.dll@0xa079 	
4 	mozcrt19.dll 	mozcrt19.dll@0xaa9d 	
5 	xul.dll 	xul.dll@0xaec173 	
6 	xul.dll 	xul.dll@0x1e2f5b 	
7 	xul.dll 	xul.dll@0x1e313f 	
8 	xul.dll 	xul.dll@0xaec173 	
9 	xul.dll 	xul.dll@0xaec748 	
10 	xul.dll 	xul.dll@0x1099f4b 	
11 	xul.dll 	xul.dll@0x887eda 	
12 	mozjs.dll 	mozjs.dll@0x868de 	
13 	mozjs.dll 	mozjs.dll@0xad435 	
14 	mozjs.dll 	mozjs.dll@0x25028f 	
15 	mozjs.dll 	mozjs.dll@0xeaabb 	
16 	mozjs.dll 	mozjs.dll@0x4e22b 	
17 	xul.dll 	xul.dll@0x8882c0 	
18 	xul.dll 	xul.dll@0x1e3165 	
19 	xul.dll 	xul.dll@0xf5311f 	
20 	xul.dll 	xul.dll@0x887eab 	
21 	xul.dll 	xul.dll@0xaec4ee 	
22 	xul.dll 	xul.dll@0x103f2c7 	
23 	xul.dll 	xul.dll@0x1099f4b 	
24 	xul.dll 	xul.dll@0x8a8ed8 	
25 	xul.dll 	xul.dll@0x103f2c7 	
26 	xul.dll 	xul.dll@0xf58b27 	
27 	xul.dll 	xul.dll@0xaec4ee 	
28 	xul.dll 	xul.dll@0x1099f4b 	
29 	xul.dll 	xul.dll@0x639120 	
30 	xul.dll 	xul.dll@0xaec8e6 	
31 	xul.dll 	xul.dll@0xaecfcb 	
32 	xul.dll 	xul.dll@0xf9638f 	
33 	xul.dll 	xul.dll@0x100a85f 	
34 	xul.dll 	xul.dll@0x1099f4b 	
35 	nspr4.dll 	nspr4.dll@0x20b65 	
36 	xul.dll 	xul.dll@0xaed5af 	
37 	xul.dll 	xul.dll@0xae6920 	
38 	nspr4.dll 	nspr4.dll@0x20537 	
39 	nspr4.dll 	nspr4.dll@0x3376f 	
40 	xul.dll 	xul.dll@0x1e71cf 	
41 	nspr4.dll 	nspr4.dll@0x3376f 	
42 	xul.dll 	xul.dll@0xae60e0 	
43 	nspr4.dll 	nspr4.dll@0x21dcf 	
44 	nspr4.dll 	nspr4.dll@0x245ac 	
45 	mozcrt19.dll 	mozcrt19.dll@0x2cc6 	
46 	mozcrt19.dll 	mozcrt19.dll@0x2d63 	
47 	mozcrt19.dll 	mozcrt19.dll@0xa45ef 	
48 	kernel32.dll 	kernel32.dll@0x1f56c 	
49 	ntdll.dll 	ntdll.dll@0x33020 	
50 	kernel32.dll 	kernel32.dll@0x9921f 	
51 	kernel32.dll 	kernel32.dll@0x9921f 	

More reports at:
http://crash-stats.mozilla.com/report/list?product=Firefox&query_search=signature&query_type=exact&query=&range_value=4&range_unit=weeks&hang_type=any&process_type=any&plugin_field=&plugin_query_type=&plugin_query=&do_query=1&admin=&signature=mozcrt19.dll%400x4ba7
I am not sure if all of these other signatures are the same bug, but there are quite a few other instances of mozcrt19.dll shoiwng up in crash stats. Maybe it makes sense to make a tracking bug?

1 	mozcrt19.dll@0x87c7
	236 	236 	0 	0 	0 	609252, More
2 	mozcrt19.dll@0x4ba7
	123 	123 	0 	0 	0 	613716, More
3 	mozcrt19.dll@0x4d1d
	62 	62 	0 	0 	0 	
4 	mozcrt19.dll@0x8fb0
	53 	53 	0 	0 	0 	
5 	mozcrt19.dll@0x514b
	42 	42 	0 	0 	0 	
6 	mozcrt19.dll@0x5147
	34 	34 	0 	0 	0 	
7 	mozcrt19.dll@0x4bb1
	24 	24 	0 	0 	0 	
8 	mozcrt19.dll@0x4ba3
	23 	23 	0 	0 	0 	
9 	mozcrt19.dll@0x8c1e
	14 	14 	0 	0 	0 	
10 	mozcrt19.dll@0x9fc7
	9 	9 	0 	0 	0 	
11 	mozcrt19.dll@0x1327f
	7 	7 	0 	0 	0 	
12 	mozcrt19.dll@0x83b8
	6 	6 	0 	0 	0 	
13 	mozcrt19.dll@0x41c34
	5 	5 	0 	0 	0 	
14 	mozcrt19.dll@0x83c7
	5 	5 	0 	0 	0 	
15 	mozcrt19.dll@0x1a0bf
	4 	4 	0 	0 	0 	
16 	mozcrt19.dll@0x4e8f
	4 	4 	0 	0 	0 	
17 	mozcrt19.dll@0x530f
	4 	4 	0 	0 	0 	
18 	mozcrt19.dll@0x5173
	4 	4 	0 	0 	0 	
19 	mozcrt19.dll@0x5204
	3 	3 	0 	0 	0 	
20 	mozcrt19.dll@0x4ead

Updated

7 years ago
Summary: Firefox/4.0b8pre 64-bit crash [@ mozcrt19.dll@0x4ba7 ] → Firefox/4.0b8pre 64-bit crash [@ mozcrt19.dll@0x4ba7 ] [@ extent_tree_ad_insert ]
(Reporter)

Comment 2

7 years ago
For extent_tree_ad_insert signature, there is a spike in crashes on Windows 64-bit from 4.0b10pre/20110112.
It is #4 topcrasher on Windows 64-bit in this build.

The regression range is:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=4413ed6ba5a5&tochange=c0e05d518f57

Meanwhile, all mozcrt19.dll@.. crash signatures have disappeared with this build.
(Reporter)

Updated

7 years ago
Keywords: topcrash
Scoobidiver, regression range of comment #2 is incorrect.  Symbol resolution support of crash reporter for Win64 build is from b10pre (see bug 618385).  So you look that this crash is spiked from 20110112.

Also, I found a Win64 jemalloc bug, so this may be fixed by bug 625315.

Updated

7 years ago
blocking2.0: --- → ?

Updated

7 years ago
blocking2.0: ? → ---

Updated

7 years ago
Depends on: 625315
(Reporter)

Comment 4

7 years ago
> Also, I found a Win64 jemalloc bug, so this may be fixed by bug 625315.
It is still #1 top crasher in 64-bit 4.0b12pre/20110206.
By bug 625753, this is fixed.  no crash from 2011-02-09 nightly
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 625753
(Assignee)

Updated

6 years ago
Crash Signature: [@ mozcrt19.dll@0x4ba7 ] [@ extent_tree_ad_insert ]
You need to log in before you can comment on or make changes to this bug.