Closed Bug 613747 Opened 12 years ago Closed 12 years ago

Small screen increase probability of being phished because of missing status bar

Categories

(Firefox :: General, defect)

All
Linux
defect
Not set
major

Tracking

()

RESOLVED FIXED

People

(Reporter: gionnico, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (X11; Linux i686; rv:2.0b7) Gecko/20100101 Firefox/4.0b7
Build Identifier: Mozilla/5.0 (X11; Linux i686; rv:2.0b7) Gecko/20100101 Firefox/4.0b7

With firefox 4 beta7 removal of the status bar, now mouse hover links cause the real link to be showed in the address bar.
But the address bar is not as long as the whole horizontal resolution.

A horizontal resolution like 800 cause too much shortening and makes phishing easier.

Reproducible: Always




It's a major feature for a browser to show the user where a link bring him, that's the point of HTTP/HTML.
The image in the URL ( http://www.forzazzurri.mine.nu/data/uploaded/horiz-800_phishing.png ) shows what happens on mouse over "Sign In" just as an example.
800px isn't exactly a mainstay resolution anymore, though I'm unsure why only part of the address bar is used for the hovered link, might as well use all of it.
This addon may be used to show link targets in fullscreen:
https://addons.mozilla.org/en-US/firefox/addon/55724/
The hovered link is intended to start in a fixed position to make it easier to spot it without having to scan across the line looking for it.  But yes it is near useless when the screen isn't wide enough, and annoying when there is room for both URLs to show completely but one or other is truncated.
This is fixed with the landing of Bug 541656
Depends on: 541656
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.