"Starting up" on the splash screen is not localizable

VERIFIED DUPLICATE of bug 100225

Status

()

Core
Internationalization
P2
normal
VERIFIED DUPLICATE of bug 100225
18 years ago
16 years ago

People

(Reporter: ji, Assigned: Simon Fraser)

Tracking

Trunk
PowerPC
Mac System 9.x
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [adt3])

(Reporter)

Description

18 years ago
This is filed as a dependent bug of bugscape 3411
At the very first screen after launch, there is a status string of "Starting 
up..." at the bottom of the screen. If we translate it to Japanese, it will show 
garbled.

Comment 1

18 years ago
Is this a generic problem or specific to Macintosh?
(Reporter)

Comment 2

18 years ago
I don't see the string on the 1st screen of windows build. And my linux machine 
is too fast to check this screen.

Comment 3

18 years ago
For Macintosh, this is localizable by editing resources ('DITL', 'ictb').
Reassign to sfraser, please investigate if there is a way to use XP string for
that string instead of Macintosh specific one.
Assignee: nhotta → sfraser
OS: Windows 95 → Mac System 9.x
Hardware: PC → Macintosh
(Assignee)

Comment 4

18 years ago
There is NO WAY to use any XP code here, because this all happens before any of 
the XPCOM services are loaded. The progress strings are currently hard-coded, but 
could be loaded from platform-specific resources if this makes l10n easier.
(Assignee)

Comment 5

18 years ago
Wontfix, since there is now way, bar resource editing, to localize that text. If 
you have to localize it, make a way, and I'll use it.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WONTFIX

Comment 6

18 years ago
Verified as wonfix.
Status: RESOLVED → VERIFIED

Comment 7

17 years ago
*** Bug 121108 has been marked as a duplicate of this bug. ***

Comment 8

17 years ago
Why is this text appearing anyway? There is no similar text on Linux or Windows.
It is redundant. The user knows Mozilla is starting up - they can see the splash
screen!

I reccomend that we remove this text entirely from OS 8.x/9 and OS X builds. It
adds a lot of extra effort on the part localisation engineers for no real gain
in terms of end user experience. It breaks the localisability guidelines and is
not localisable at all on OS X.

Reopening, Nominating.
Status: VERIFIED → REOPENED
Keywords: nsbeta1
Priority: P3 → P2
Resolution: WONTFIX → ---

Comment 9

17 years ago
well, seems other platforms were planning to add some status text to the 
splash also. see bug:
http://bugzilla.mozilla.org/show_bug.cgi?id=35866
http://bugzilla.mozilla.org/show_bug.cgi?id=66898

Comment 10

17 years ago
For Mac, to make it easier for localization, the DITL rsrc should not contain 
any strings. All text should be in STR#.
(Assignee)

Comment 11

17 years ago
I can put the text in a STR# easily enough. But we are going to keep text in the 
splash screen, and add more notifications. It's an important part of the user 
experience during our all-too-long startup period.
Status: REOPENED → ASSIGNED

Comment 12

17 years ago
agree.
But, without XP code, is it easy to put all localiable strings (STR#) into a 
text file, like an ini separated with the app? That way, we won't need to touch 
the app too much, just change the language in "vers".
This is just my personal opinion, maybe too excessive, heehee, sorry ;-)

Comment 13

17 years ago
"hard coding" strings like this into the app is a Bad Thing. It requires extra
work for localisation engineers. Hardcoding strings outside the existing XP
packages adds risk that the engineer might break something while localising
which requires additional QA time. This is a multiple of the number of
languages. This makes it very difficult to ship simultaneous or ever timely Mac
builds. It also costs money - probably 2 man weeks per year across all the
languages. 

I still do not see a good reason for this text. Mac startup time is much better
than when this hack was created.  There are better ways to show startup progress
than displaying localisable text such as progress bars or icons.
(Assignee)

Updated

17 years ago
Depends on: 100225
Summary: "Starting up" on the very first screen is not localizable → "Starting up" on the splash screen is not localizable

Comment 14

16 years ago
Simon - Is this something you can get to before you leave?
Whiteboard: [adt3]
(Assignee)

Comment 15

16 years ago
Dupping to the more general bug 100225.

*** This bug has been marked as a duplicate of 100225 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago16 years ago
Resolution: --- → DUPLICATE

Comment 16

16 years ago
Verified as dup.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.