In RTL UI, the arrow appears on the wrong side of the "Remember password" panel

RESOLVED FIXED

Status

()

Core
XP Toolkit/Widgets: XUL
--
major
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: smontagu, Unassigned)

Tracking

({rtl})

unspecified
Points:
---
Bug Flags:
in-testsuite ?

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
Created attachment 492162 [details]
Screenshot

Steps to reproduce:

1) Set intl.uidirection.en-US to "rtl" in about:config and restart the browser (or use an RTL localization)
2) Enter a new password in some website login page
3) Expected results: the "Remember password" panel appears, with the arrow pointing to the key icon to the left of the URL (Note that the URL bar is always LTR, even in RTL UI)
4) Actual results: the panel is aligned with the left end of the URL bar, as expected, and the UI of the panel itself is reversed, also as expected; but the arrow is on the top right instead of top left, pointing to somewhere in the middle of the URL.

This is reproducible on Windows and OS X but not on Linux.
(Reporter)

Comment 1

7 years ago
I think this should block, even though it doesn't make the UI non-functional, because it looks @#$%-ugly and unprofessional.
blocking2.0: --- → ?

Comment 2

7 years ago
Patches in bug 606343 should fix this. Likely, only part 4 is necessary.
Simon, please renom if this wasn't fixed by bug 606343.
blocking2.0: ? → ---
(Reporter)

Comment 4

7 years ago
Fixed in current nightlies
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Flags: in-testsuite?
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.