PDF-plugin breaks Firefox window Unicode title

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
8 years ago
7 years ago

People

(Reporter: Huji, Unassigned)

Tracking

3.6 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.12) Gecko/20101026 Firefox/3.6.12
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.12) Gecko/20101026 Firefox/3.6.12

If you open a PDF inside Firefox using the PDF plugin, then try to open a page in another tab which has a non-ASCII title, the title of Firefox window and the title of the tab will be rendered as a bunch of question marks.

Reproducible: Always

Steps to Reproduce:
1. Open a tab, and open a PDF file from the internet in this tab using PDF plugin.
2. Open a second tab and browse to http://fa.wikipedia.org/wiki/
3. While you are still in the second tab, look at the title of Firefox window, or the title of this tab. Instead of the Persian words "ویکی‌پدیا، دانشنامهٔ آزاد" you will see a set of question marks.
Actual Results:  
Question marks in window title.

Expected Results:  
Unicode characters in window title.

The version of PDF plugin I'm using:

    File: nppdf32.dll
    Version: 9.0.0.332
    Adobe PDF Plug-In For Firefox and Netscape

Comment 1

8 years ago
That has nothing to do with the PDF plugin itself, I think - it's Windows that can't display the title properly if the corresponding language support isn't installed. But Firefox can, so it's possible that you see the correct title in the tab (drawn by the browser), as opposed to the window title (drawn by the OS). The icon it the task bar is actually drawn correctly (I forgot what the technical reason is that it's drawn in the task bar, but not in the title bar).

I can what you describe, but when I open only a single tab with the test-URL inside (immediately after startup), I'm not seeing the question marks, but empty boxes, which is the character that is drawn when the OS can't draw the character. That's on Windows XP without any language packs installed. It's only after a PDF document was opened, that the title bar starts to show question marks instead. That's a bit weird (what did Acrobat do with the OS to provoke this ?), but it's not much better than the original boxes.

Comment 2

8 years ago
Oh, that's right, I'm not seeing your bug on Firefox 4.0 anymore. That is, I'm still seeing the empty boxes, but they don't change to question marks. That's probably because Acrobat is running out-of-process in 4.0, while it was still in-process in 3.6.12.
(Reporter)

Comment 4

8 years ago
Jo,

I'm afraid you're wrong. First, Firefox shows the title correctly (in Unicode) before a PDF is viewed inside a tab using the plug-in (I have that language installed on my Windows). Second, both the title of the window "AND" the tab are changed to question marks (so it is not an OS issue, but a firefox/plug-in issue.
(Reporter)

Comment 5

8 years ago
Marrhias,

My bad; I should have searched more before posting the bug. But yes, I'm basically talking about the same thing.

It appears to me that after using the PDF plug-in, Firefox's window somehow changes into a non-Unicode mode.

Comment 6

8 years ago
(In reply to comment #4)
> Jo,
> 
> I'm afraid you're wrong. First, Firefox shows the title correctly (in Unicode)
> before a PDF is viewed inside a tab using the plug-in (I have that language
> installed on my Windows). Second, both the title of the window "AND" the tab
> are changed to question marks (so it is not an OS issue, but a firefox/plug-in
> issue.

I do not have Chinese installed - that's why I see the empty boxes. The question marks seem to come from the PDF plugin somehow. At least on 3.6, I'm not seeing a difference on 4.0.

Updated

8 years ago
Version: unspecified → 3.6 Branch
(Reporter)

Comment 7

7 years ago
I just wanted to mention that I've upgraded to Firefox 4.0 and this bug is not reproducible in this version anymore. While we may still think Adobe's plugin is to blame for this bug, Firefox 4.0 is somehow getting around the plugin's issue, which is good news :)

Comment 8

7 years ago
Closing per comment 7
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.