Firefox crashes in Google image search when scrolling down [@ NPSWF32.dll@0xe3803]

RESOLVED WORKSFORME

Status

--
critical
RESOLVED WORKSFORME
8 years ago
3 years ago

People

(Reporter: t8av, Unassigned)

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2.12) Gecko/20101026 BTRS28059 Firefox/3.6.12 ( .NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2.12) Gecko/20101026 BTRS28059 Firefox/3.6.12 ( .NET CLR 3.5.30729)

When I use Google image search (the new version, with lots of images in one page), if I scroll down too fast (faster than the images load), firefox crashes.


Reproducible: Always

Steps to Reproduce:
1. Go to Google image search and look for any keyword. For example: http://www.google.com/images?source=imghp&q=flower

2. Scroll down faster than the images load to the page. Probably to reproduce the crash - the faster the better.

Actual Results:  
Firefox crashes

Expected Results:  
Images may load slow, but firefox should not crash.
(Reporter)

Comment 1

8 years ago
The problem occurs only sometimes. Maybe only when there are many open tabs already.

If you cannot reproduce the problem - Try to open many tabs with Google image search (scroll down fast for every new tab) until you see the crash.
(Reporter)

Comment 3

8 years ago
The last crash:

http://crash-stats.mozilla.com/report/index/af817a4f-3a4d-4cca-9224-c55962101122

I will submit more reports when more crashes happen.
The flash plugin is crashing and you are using an old version of flash.
"NPSWF32.dll 	10.0.2.54"

Please upgrade your flash plugin and try it again.

Comment 5

8 years ago
Signature	NPSWF32.dll@0xe3803
UUID	af817a4f-3a4d-4cca-9224-c55962101122
Time 	2010-11-22 05:05:25.727365
Uptime	19440
Install Age	609372 seconds (1.0 weeks) since version was first installed.
Product	Firefox
Version	3.6.9
Build ID	20100824153629
Branch	1.9.2
OS	Windows NT
OS Version	6.0.6002 Service Pack 2
CPU	x86
CPU Info	GenuineIntel family 6 model 23 stepping 7
Crash Reason	EXCEPTION_ACCESS_VIOLATION_READ
Crash Address	0x0
User Comments	
Processor Notes 	
EMCheckCompatibility	False
Crashing Thread
Frame 	Module 	Signature [Expand] 	Source
0 	NPSWF32.dll 	NPSWF32.dll@0xe3803 	
1 		@0x6e0068 	
2 	NPSWF32.dll 	NPSWF32.dll@0xbc2d2 	
3 	NPSWF32.dll 	NPSWF32.dll@0xbfdd0 	
4 	NPSWF32.dll 	NPSWF32.dll@0x4242b 	
5 	NPSWF32.dll 	NPSWF32.dll@0x5bfa4 	
6 	NPSWF32.dll 	NPSWF32.dll@0x5bfba 	
7 	NPSWF32.dll 	NPSWF32.dll@0x5bfda 	

Filename 	Version 	Debug Identifier 	Debug Filename
NPSWF32.dll 	10.0.2.54 	E214D1CB28F545C9A386B7554CD5410F1 	NPSWF32.pdb

hopefully this is fixed in a current version of flash. please confirm.
Severity: normal → critical
Component: General → Flash (Adobe)
Keywords: crash
Product: Firefox → Plugins
QA Contact: general → adobe-flash
Summary: Firefox crashes in Google image search when scrolling down → Firefox crashes in Google image search when scrolling down [@ NPSWF32.dll@0xe3803]
Version: unspecified → 10.x
(Reporter)

Comment 6

8 years ago
Well, I uninstalled the flash plugin and re-installed it.

When entering Google image search, this time only one tab crashed (stopped responding), not the entire browser, so there was no new crash entry at about:crashes.

Comment 7

8 years ago
for the record, what version of flash are you now using? :)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 8

8 years ago
Tools -> Add-ons -> Plugins -> Shockwave flash 10.1.102.64
(Reporter)

Comment 9

8 years ago
Maybe the word "crash" was incorrect. Actually it is extreme slowness which makes the browser unusable. It always happens when I go to Google image search and scroll down. At a certain point the browser suddenly starts to react extremely slow and becomes unusable.

There are no crash reports in about:crashes because the browser did not entirely crash (but was very close to it). It means that I don't know how to send you reports about this when it occurs.

Comment 10

8 years ago
your initial report was a crash. slowness is roughly like hanging, except much better.

you'd need a new bug report.

https://developer.mozilla.org/En/How_to_get_a_stacktrace_with_WinDbg

see the part about hangs.
(Reporter)

Comment 11

8 years ago
Well, I uninstalled plugin "Microsoft .NET framework assistant 1.2.1" and so far the problem did not repeat (extreme slowness).

However, one time the browser disappeared. It looks like crash but still the download window was still open and no crash report was in about:crashes.

Comment 12

8 years ago
if the download window was still open, it wasn't a crash, it'd mean something trusted decided you asked it to close a browser window (more or less) .. in theory you could have clicked a js link in window A which opened a window B; you could have closed window A yourself; since window B was opened by a web page, it's allowed to be closed by a web page....
(Assignee)

Updated

8 years ago
Crash Signature: [@ NPSWF32.dll@0xe3803]

Comment 13

3 years ago
Version and milestone values are being reset to defaults as part of product refactoring.
Version: 10.x → unspecified
You need to log in before you can comment on or make changes to this bug.