M081 crash [@ MSVCRT.DLL - nsStorageInputStream::Read]

VERIFIED FIXED in mozilla0.9

Status

()

Core
Networking: Cache
P3
normal
VERIFIED FIXED
18 years ago
17 years ago

People

(Reporter: jay, Assigned: gordon)

Tracking

({crash, topcrash})

Trunk
mozilla0.9
x86
All
crash, topcrash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

18 years ago
This is one of the topcrashers with the official RTM build under the MSVCRT.DLL
stack signature.  Due to the lack of helpful user comments in the talkback
entries, the steps to reproduce are unknown.  All I have is a stack trace:

Incident ID 21912137
MSVCRT.DLL + 0x11ce (0x780011ce)
nsStorageInputStream::Read
[d:\builds\seamonkey\mozilla\xpcom\io\nsStorageStream.cpp, line 429]
AsyncReadStreamAdaptor::Read
[d:\builds\seamonkey\mozilla\netwerk\cache\memcache\nsMemCacheChannel.cpp, line 171]
nsParser::OnDataAvailable
[d:\builds\seamonkey\mozilla\htmlparser\src\nsParser.cpp, line 2304]
nsDocumentOpenInfo::OnDataAvailable
[d:\builds\seamonkey\mozilla\uriloader\base\nsURILoader.cpp, line 260]
nsHTTPFinalListener::OnDataAvailable
[d:\builds\seamonkey\mozilla\netwerk\protocol\http\src\nsHTTPResponseListener.cpp,
line 1196]
nsHTTPCacheListener::OnDataAvailable
[d:\builds\seamonkey\mozilla\netwerk\protocol\http\src\nsHTTPResponseListener.cpp,
line 192]
AsyncReadStreamAdaptor::OnDataAvailable
[d:\builds\seamonkey\mozilla\netwerk\cache\memcache\nsMemCacheChannel.cpp, line 112]
nsOnDataAvailableEvent::HandleEvent
[d:\builds\seamonkey\mozilla\netwerk\base\src\nsAsyncStreamListener.cpp, line 406]
nsStreamListenerEvent::HandlePLEvent
[d:\builds\seamonkey\mozilla\netwerk\base\src\nsAsyncStreamListener.cpp, line 106]
PL_HandleEvent [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, line 581]
PL_ProcessPendingEvents [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c,
line 517]
_md_EventReceiverProc [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, line
1051]
nsAppShellService::Run
[d:\builds\seamonkey\mozilla\xpfe\appshell\src\nsAppShellService.cpp, line 408]
NETSCP6.EXE + 0x1694 (0x00401694)
NETSCP6.EXE + 0x11b8 (0x004011b8)
NETSCP6.EXE + 0x2a4a (0x00402a4a)
KERNEL32.DLL + 0x7903 (0x77e57903)
(Reporter)

Comment 1

18 years ago
Adding crash, topcrash keywords and [@ nsStorageInputStream::Read]
 for tracking.  Here are some entries with user comments:

CrashDate: 2000-11-27 UptimeMinutes: 3  Total: 3 OS: Windows 98  4.10 build 67766446
	 Incident ID: http://climate/reports/stackcommentemail.cfm?dynamicBBID=21881778
Comment: using simple browsing features...  I was just at my local bank website
and I recieved an error message when using the back button.  This update of
Netscape crashed within the first 3 min of using it!!!
------------
CrashDate: 2000-11-27 UptimeMinutes: 208  Total: 208 OS: Windows 95  4.0 build
67306684
	 Incident ID: http://climate/reports/stackcommentemail.cfm?dynamicBBID=21866626
URL: ebay.com
	 Comment: opening item to view
---------
CrashDate: 2000-11-27 UptimeMinutes: 8  Total: 271 OS: Windows 95  4.0 build
67306684
	 Incident ID: http://climate/reports/stackcommentemail.cfm?dynamicBBID=21846092
URL: netscape.com smart updates
	 Comment: am trying to download java 2 plugin v1.3error encountered 228

Keywords: crash, topcrash
(Reporter)

Updated

18 years ago
Summary: RTM crash [@ nsStorageInputStream::Read] → RTM crash #2 [@ nsStorageInputStream::Read (MSVCRT.DLL)]

Comment 2

18 years ago
Pretty strange that the memory cache shows up on the stack trace since the
memory cache is disabled for the browser (mail is the only consumer)

Comment 3

18 years ago
*** Bug 61397 has been marked as a duplicate of this bug. ***

Comment 4

18 years ago
This bug should be resolved when the new cache code lands.
Target Milestone: --- → mozilla0.9

Comment 5

18 years ago
Cache bugs to Gordon
Assignee: neeti → gordon

Comment 6

18 years ago
Using nscatfood keyword to track crash car bugs.
Keywords: nsCatFood
(Reporter)

Comment 7

18 years ago
This is still a topcrasher for the lastest mozilla 0.8.1 release.  Adding M081 
to summary for tracking. Also adding qawanted keyword to get some help 
reproducing this crash.

 Most of the user comments say this crash occurs in mail (no further details 
submitted) and the latest stack trace about the same as before:

Incident ID 28314611 
MSVCRT.DLL + 0x11ce (0x780011ce) 
nsStorageInputStream::Read 
[d:\builds\0.8.1\mozilla\xpcom\io\nsStorageStream.cpp, line 429] 
AsyncReadStreamAdaptor::Read 
[d:\builds\0.8.1\mozilla\netwerk\cache\memcache\nsMemCacheChannel.cpp, line 171] 
ImageConsumer::OnDataAvailable 
[d:\builds\0.8.1\mozilla\gfx\src\nsImageNetContextAsync.cpp, line 416] 
nsDocumentOpenInfo::OnDataAvailable 
[d:\builds\0.8.1\mozilla\uriloader\base\nsURILoader.cpp, line 261] 
nsHTTPFinalListener::OnDataAvailable 
[d:\builds\0.8.1\mozilla\netwerk\protocol\http\src\nsHTTPResponseListener.cpp, 
line 1164] 
nsHTTPCacheListener::OnDataAvailable 
[d:\builds\0.8.1\mozilla\netwerk\protocol\http\src\nsHTTPResponseListener.cpp, 
line 197] 
AsyncReadStreamAdaptor::OnDataAvailable 
[d:\builds\0.8.1\mozilla\netwerk\cache\memcache\nsMemCacheChannel.cpp, line 112] 
nsOnDataAvailableEvent0::HandleEvent 
[d:\builds\0.8.1\mozilla\netwerk\base\src\nsAsyncStreamListener.cpp, line 419] 
nsStreamListenerEvent0::HandlePLEvent 
[d:\builds\0.8.1\mozilla\netwerk\base\src\nsAsyncStreamListener.cpp, line 107] 
PL_HandleEvent [d:\builds\0.8.1\mozilla\xpcom\threads\plevent.c, line 589] 
PL_ProcessPendingEvents [d:\builds\0.8.1\mozilla\xpcom\threads\plevent.c, line 
522] 
_md_EventReceiverProc [d:\builds\0.8.1\mozilla\xpcom\threads\plevent.c, line 
1070] 
nsAppShellService::Run 
[d:\builds\0.8.1\mozilla\xpfe\appshell\src\nsAppShellService.cpp, line 408] 
main1 [d:\builds\0.8.1\mozilla\xpfe\bootstrap\nsAppRunner.cpp, line 1011] 
main [d:\builds\0.8.1\mozilla\xpfe\bootstrap\nsAppRunner.cpp, line 1301] 
WinMain [d:\builds\0.8.1\mozilla\xpfe\bootstrap\nsAppRunner.cpp, line 1319] 
WinMainCRTStartup() 
KERNEL32.DLL + 0x192a6 (0x77e992a6) 
Keywords: qawanted
Summary: RTM crash #2 [@ nsStorageInputStream::Read (MSVCRT.DLL)] → M081 crash [@ MSVCRT.DLL - nsStorageInputStream::Read]
(Assignee)

Comment 8

17 years ago
This was with the old cache.  Marking FIXED.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 9

17 years ago
verified - old cache problem
Status: RESOLVED → VERIFIED

Updated

17 years ago
Keywords: qawanted
Crash Signature: [@ MSVCRT.DLL - nsStorageInputStream::Read]
You need to log in before you can comment on or make changes to this bug.