Closed Bug 614094 Opened 9 years ago Closed 9 years ago

JavaScript "prompt" function does not work in Fennec

Categories

(Firefox for Android Graveyard :: General, defect, major)

defect
Not set
major

Tracking

(fennec2.0b3+)

VERIFIED FIXED
Tracking Status
fennec 2.0b3+ ---

People

(Reporter: nhirata, Assigned: mbrubeck)

References

Details

(Keywords: regression)

Attachments

(1 file)

Mozilla/5.0 (Android; Linux armv71; rv2.0b8pre) Gecko/20101122 Firefox/4.0b8pre Fennec/4.0b3pre
Mozilla/5.0 (Maemo; Linux armv71; rv:2.0b8pre) Gecko/20101122 Firefox/4.0b8pre Fennec/4.0b3pre

1. go to http://people.mozilla.com/~nhirata/html_tp/PasswordPrompt.html
2. go to error console

Expected: JS prompt for password
Actual: blank screen, error in console:
Error: uncaught exception: [Exception... "[JavaScript Error: "browser is null"
{file: "jar:file:///data/app/org.mozilla.fennec-2.apk!/components/PromptService.js" line: 218}]' when calling method: [nsIPrompt::prompt]" nsresult: "0x80570021 (NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)" location: "JS frame :: http://people.mozilla.com/~nhirata/html_tp/PasswordPrompt.html ::checkPasswd :: line 11" data: yes]
This will be fixed by bug 610492.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 610492
Actually, since this is a highly visible regression from bug 59314, I think we should take a simple fix for b3, and wait until b4 for bug 610492.
Assignee: nobody → mbrubeck
Blocks: 59314
Severity: normal → major
Status: RESOLVED → REOPENED
tracking-fennec: --- → ?
Keywords: regression
Hardware: ARM → All
Resolution: DUPLICATE → ---
Summary: JS Password prompt does not work; JavaScript Error: "browser is null" in error console → JavaScript "prompt" function does not work in Fennec
Attached patch patchSplinter Review
This remotes all of the nsIPrompt methods used in nsGlobalWindow.cpp, http://hg.mozilla.org/mozilla-central/rev/1fc05b5edd02

This should block Fennec beta3.
Attachment #492526 - Flags: review?(mark.finkle)
tracking-fennec: ? → 2.0b3+
Comment on attachment 492526 [details] [diff] [review]
patch

technically we don't use {} around 1-liners. Add a blank line after the |if|
Attachment #492526 - Flags: review?(mark.finkle) → review+
Pushed with brace/whitespace fixes:
http://hg.mozilla.org/mobile-browser/rev/a73a61afbd51
Status: REOPENED → RESOLVED
Closed: 9 years ago9 years ago
Resolution: --- → FIXED
Verified:

Mozilla/5.0 (Android; Linux armv71; rv2.0b8pre) Gecko/20101123 Firefox/4.0b8pre Fennec/4.0b3pre
Mozilla/5.0 (Maemo; Linux armv71; rv:2.0b8pre) Gecko/20101123 Firefox/4.0b8pre Fennec/4.0b3pre
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.