problems with stylesheets and multi-part jpegs

RESOLVED WORKSFORME

Status

()

P3
normal
RESOLVED WORKSFORME
18 years ago
16 years ago

People

(Reporter: inkumbi, Assigned: pavlov)

Tracking

Trunk
Future
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
My webcam (using the camserv software) saves images as multi-part jpegs, which
display on a page to give the impression of a "streaming" image. However, if I
use a stylesheet link, the image fails to appear.

I suspect this has to do with a behaviour in mozilla first downloads all images,
followed by stylesheet links, so it only begins to download the image, then
stops, downloads the stylesheet, and thinks all the images have finished
downloading... or something of the sort.

Try and stick <IMG SRC="http://www.treehouse.org.za:9192"> in a page first
without a stylesheet link, then with one (such as <LINK rel="stylesheet"
type="text/css" href="../style.css">) ... I apologise if you're forced to view
my ugly mug ;)

Thanks!

Comment 1

18 years ago
updating component.
Assignee: asa → gagan
Component: Browser-General → Networking
QA Contact: doronr → tever
webcam url worksforme linux build 2000-11-27-08

Tim, do you see this problem with a recent Mozilla build?
(Reporter)

Comment 3

18 years ago
Yep, on the 20001128 nightly build. There seems to be more to this problem than
I first reported.
The problem only occurs in one of three situations:
1) When viewing a local page (in the form of file:///var/www/webcam/index.html)
the image is displayed correctly.
2) When viewing a page not on the localhost (which is www.treehouse.org.za), but
linking to http://www.treehouse.org.za:9192, the page displays (as from
http://www.serendipity.org.za/~tim/webcam.html)
3) When viewing the page on the _local_ server... ie. fetching the page from the
server on the localhost, the problem occurs... it results in a page being
displayed without the image...
... and I've just discovered something else... when viewed from
http://treehouse.org.za/webcam/, it displays, but when viewed at the URL
http://www.treehouse.org.za/webcam/ it doesn't... the problem appears to be only
when the page links to the URL http://www.treehouse.org.za:9192. When linking to
http://treehouse.org.za:9192, the problem is reversed. 
And I've drawn a complete blank as to why this could be :) It is, however,
reproducible. If it helps, mozilla prints out
Document http://treehouse.org.za/webcam/ loaded successfully 
			when the image is _not_ being displayed, but 
Error loading URL http://www.treehouse.org.za/webcam/: 804b0002
			when this image _is_ displayed correctly.

Comment 4

18 years ago
I am seeing this.
Platform: PC
OS: Linux 2.2.16
Mozilla Build: 2000122208 M18 Trunk

Marking as New.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 5

18 years ago
It appears that this bug has been corrected, the page displays correctly despite
the URL. Thanks to whoever fixed it. :)

Marking as Fixed.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Reporter)

Comment 6

18 years ago
This bug reappeared in around March, and I am still seeing it in the latest
build, 2001062221 (Linux 2.4.2, PC).

It seems slightly different from its previous incarnation: none of the special
cases that applied there are no longer applicable... the jpeg appears on the
screen for an instant and then disappears as if it were never there.

No debugging output is printed on stdout.

Thanks!
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 7

18 years ago
dougt did you fix this recently?
Assignee: gagan → dougt
Status: REOPENED → NEW

Comment 8

18 years ago
this bug is morphing....

I am seeing the same as Tim, but on the console, I see:

JPEG decoding error:
Not a JPEG file: starts with 0x0a 0xff

Over to pavlov.
Assignee: dougt → pavlov
(Reporter)

Comment 9

18 years ago
I no longer see this bug in build 20001071708... leaving it as NEW, in case you
guys have something else planned :)

You guys continue to amaze me, quick work! Thanks!

Comment 10

17 years ago
I am unable to view this webcam on linux build 61414

Comment 11

17 years ago
been meaning to report this one for months...

This still doesn't work correctly here (Mozilla/5.0 (X11; U; Linux i686; en-US;
rv:0.9.5+) Gecko/20011115), just displays the first frame and stops. FWIW, the
data source here is from Axis network cameras.

The problem is *not* stylesheet related; it behaves the same with the
(non-stylesheeted) Axis motion JPEG page and with my own monitor page which has
a stylesheet.

The bug has moved over time; Mozilla used to display maybe 10-15 seconds of
streaming data before stopping, so whatever fixes have gone in have made things
worse...

This is the last bug that is stopping me using Mozilla for everything I do on
the web - when it is fixed, I can finally consign NS4 to /dev/null where it belongs.
(Assignee)

Updated

17 years ago
Target Milestone: --- → Future

Comment 12

17 years ago
This is a dupe of another multipart JPEG bug which was fixed.
bug 42224 describes the current issue with multipart JPEGs
->WFM
Status: NEW → RESOLVED
Last Resolved: 18 years ago17 years ago
Resolution: --- → WORKSFORME

Updated

16 years ago
QA Contact: tever → benc
You need to log in before you can comment on or make changes to this bug.