When ui.use_native_popup_windows is enabled, selectboxes won't work

RESOLVED DUPLICATE of bug 548734

Status

()

Core
Layout: Form Controls
--
minor
RESOLVED DUPLICATE of bug 548734
8 years ago
7 years ago

People

(Reporter: Rene Pot, Unassigned)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.12) Gecko/20101026 Firefox/3.6.12
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.12) Gecko/20101026 Firefox/3.6.12

Whenever I enable ui.use_native_popup_windows (so value is true), on every website the selectboxes won't work. They won't open, but I still can use them with arrow keys.

Reproducible: Always

Steps to Reproduce:
1. go to about:config
2. set ui.use_native_popup_windows to true
3. go to a random website with HTML-selectboxes
4. Click on selectbox
Actual Results:  
At step 4, the selectboxes won't show (open). But stay closed and you need to select a value with arrow keys, or by typing

Expected Results:  
Selectbox should show.

I have tested this with my firefox version on 2 different operation systems.

Firefox 3.6.12
Windows XP
Windows 7

Plugins installed on both systems (going to try without plugins installed after this report submit)
FireBug
ReloadEvery
Developer Toolbar
LiveHTTPHeaders
(Reporter)

Comment 1

8 years ago
Without plugins this error also occurs
(Reporter)

Comment 2

8 years ago
Update: Firefox4 Beta7 also has this error.

Updated

8 years ago
Version: unspecified → 3.6 Branch

Updated

7 years ago
Duplicate of this bug: 662269

Updated

7 years ago
OS: Windows 7 → All

Comment 4

7 years ago
Reproduced:
Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.9.2.17) Gecko/20110420 Firefox/3.6.17
Mozilla/5.0 (X11; Linux x86_64; rv:2.0.1) Gecko/20100101 Firefox/4.0.1
Mozilla/5.0 (X11; Linux x86_64; rv:5.0) Gecko/20100101 Firefox/5.0
Mozilla/5.0 (X11; Linux x86_64; rv:6.0a2) Gecko/20110606 Firefox/6.0a2
Mozilla/5.0 (X11; Linux x86_64; rv:7.0a1) Gecko/20110606 Firefox/7.0a1

Last good nightly: 2009-07-06 First bad nightly: 2009-07-07

Pushlog: http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=b4fee3813956&tochange=2f6cb9dc1f13

But this is a duplicate of bug 548734.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Component: General → Layout: Form Controls
Product: Firefox → Core
QA Contact: general → layout.form-controls
Resolution: --- → DUPLICATE
Version: 3.6 Branch → Trunk
Duplicate of bug: 548734
You need to log in before you can comment on or make changes to this bug.