Status

mozilla.org Graveyard
Server Operations
RESOLVED FIXED
8 years ago
3 years ago

People

(Reporter: timeless, Assigned: timeless)

Tracking

Details

(Assignee)

Description

8 years ago
konigsberg is using 99% of its 90gb allocation. before I ask for more space, I'd like to try to clean it up a but. I'm running a tool from sp3000 to find stuff I don't need. I'll report things here.

In general, if I don't need these items, it'd be good if they could be removed.
(Assignee)

Comment 1

8 years ago
[timeless@konigsberg ~]$ find /usr/src/kernels -mindepth 1 -maxdepth 1|xargs -n1 rpm -q -f
kernel-devel-2.6.18-194.26.1.el5
kernel-devel-2.6.18-194.3.1.el5
kernel-devel-2.6.18-194.17.4.el5

It's possible I need one of these, but I'm hoping I don't need three.
(Assignee)

Comment 2

8 years ago
I had ~1gb of data in home. I've removed a bit of it. Some of it can be moved to another server (dreamhost).

There seems to be roughly 1gb of files in /var, fox2mike will look and probably clean out some of it.

There's 150mb of files in  /data/mxr-data/*/*log -- but right now I need data like that as I'm chasing something which we're hoping is a regression.

So far nothing else has popped up, so it looks like konigsberg really just has lots of data in /data/mxr-data -- which is precisely what it's supposed to have.
(Assignee)

Comment 3

8 years ago
Oh, there is 3.6gb of data in databases composing of /data/mxr-data/*/{fileidx,xref}

Assuming that a database will be 5% or so of the live data that would indicate the data is roughly in line.

Right now df says:

95G   Total
87G   Used
3.2G  Avail
97%   Utilitization

Comment 4

8 years ago
What's IT's action here?  Can you assign the bug to yourself until there's something you need us to do?
(Assignee)

Comment 5

8 years ago
yeah, sorry.

i found one mxr root which was supposed to have moved.

IT Actions: please remove any kernel source packages from comment 1 if they aren't needed.
Assignee: server-ops → timeless
(In reply to comment #5)

> IT Actions: please remove any kernel source packages from comment 1 if they
> aren't needed.

So we'd need to reboot the box (so it uses a new kernel) before I can remove the other 2 older ones.
(Assignee)

Comment 7

8 years ago
Linux konigsberg.nl.mozilla.org 2.6.18-194.3.1.el5 #1 SMP Thu May 13 13:09:10 EDT 2010 i686 athlon i386 GNU/Linux

 20:33:08 up 68 days, 23:31,  3 users,  load average: 0.00, 0.00, 0.00

ah, well, yeah, i think having it reboot wouldn't be a big deal. is that something that should happen regularly? :)

Lemme make a few other notes and then i'll give you a go ahead.
(Assignee)

Comment 8

8 years ago
mxr-data accounts for 79G     total

the biggest of them are:
1.1G    comm-central
1.2G    mozilla-central
1.3G    dev-w3
1.5G    cvs.mozilla.org
1.5G    mozilla
2.3G    chromium
6.6G    projects-central
7.7G    addons
7.9G    mozdev-cvs
9.3G    mozillasvn-all
21G     mozillausers-central

which account for 61+G

yes chromium isn't mozilla, but it's actually useful to have for mozilla users (i need to get it cron'd). dev-w3 is also not mozilla, but it is also mozilla related.

I found one more .5 gb mxr-data directory which was supposed to have moved and deleted it. That brings me to 7.2GB (7% of the disk is theoretically available, I presume nagios willl complain when i drop below 5%).

I'll probably investigate at some point switching mxr from dealing w/ svn to using hgsubversion to deal w/ svn, however i expect that to be loads of fail, since from memory mozillasvn is like most annoying svn repos: it doesn't have a single place for branches. That'll mean I'll need to actually spend time trying to write a script to teach mxr how to divine what branches are and then to walk hgsubversion through them. This'll require the current svn repo + space + time :).

I think at this point I'm relatively comfortable w/ considering making a request for a larger disk allocation.

fox2mike: would it make sense to have konigsberg go to sleep and wake up w/ a larger disk allocation (instead of having it die just to update the kernel and some time later die again to get more disk)?

I don't need uptime, but I also don't like making repeated requests to kick a box. So if it makes sense for me to ask for more space first, I can do that.
(In reply to comment #5)
> yeah, sorry.
> 
> i found one mxr root which was supposed to have moved.
> 
> IT Actions: please remove any kernel source packages from comment 1 if they
> aren't needed.

IT doesn't manage this box. I do. You should be poking me for this stuff.
(Assignee)

Comment 10

8 years ago
oops, sorry. is there a better component than this one? it doesn't belong in community giving, and it isn't really mxr.
(In reply to comment #10)
> oops, sorry. is there a better component than this one? it doesn't belong in
> community giving, and it isn't really mxr.

If you need more disk space, this is the right component. If you just need normal admin-type stuff (like kernel management) done, just poke me on IRC or e-mail me.
Reopen if there's something for IT to do.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Product: mozilla.org → mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.