All users were logged out of Bugzilla on October 13th, 2018

pure ASCII text is not readable

VERIFIED INVALID

Status

()

P3
major
VERIFIED INVALID
18 years ago
18 years ago

People

(Reporter: primorec, Assigned: pierre)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(8 attachments)

(Reporter)

Description

18 years ago
Pure ASCII text written in the TABLE is not readable. It is white instead of
black.Please check attached GIF files

MSIE shows the same page/table corectly

Igor

system: Mozilla/5.0 (X11; U; Linux 2.2.14-5.0 i686; en-US; m18) Gecko/20001010
(Reporter)

Comment 1

18 years ago
Created attachment 19857 [details]
page seen by M18
(Reporter)

Comment 2

18 years ago
Created attachment 19858 [details]
page seen by NS4.7
(Reporter)

Comment 3

18 years ago
Created attachment 19859 [details]
page seen by MSIE - table is readable
(Reporter)

Comment 4

18 years ago
Created attachment 19860 [details]
page seen by M18 - table is not readable
(Reporter)

Comment 5

18 years ago
Created attachment 19861 [details]
page seen by NS4.7 - table is not readable
(Reporter)

Comment 6

18 years ago
Created attachment 19862 [details]
page seen by MSIE - table is readable
(Reporter)

Comment 7

18 years ago
can somebody find out WHY M18 corrupts GIF attachments ?? This is a MAJOR reason
why I am attaching all 3 GIF files for the second time. Second sets of GIF files
have been attached with NS4.7 !!  First set of 3 GIF files was attached with M18
and the files are corrupted.

Comment 8

18 years ago
Igor: I think that was fixed after m18, if you want me to look i can. -but I 
need to sleep-

Updated

18 years ago
Assignee: asa → pierre
Status: UNCONFIRMED → NEW
Component: Browser-General → Style System
Ever confirmed: true
OS: Linux → All
QA Contact: doronr → chrisd

Comment 9

18 years ago
Confirmed with 113004 win32 build on NT.  Testcase follows. over to stylesystem.
not sure if we're right or wrong on this but in mozilla and nav4.x the text in
this table displays with color from the <body text="#FFFFFF"> and in IE the text
is displayed with the color from the <table style="color: #000000">.

<html>
<body text="#FFFFFF">

<table style="color:#000000">
<tr>
<td style="background:#CCCCCC">
This text is BLACK in IE 5.5  and it is WHITE in Navigator 4.x and Mozilla.
</td>
</table>
</html>

Comment 10

18 years ago
Created attachment 19978 [details]
testcase demonstrating font color pronblem
(Assignee)

Comment 11

18 years ago
It is a quirk from Nav4x where the table cell color is not inherited from the 
table itself but from its parent element.  That quirk was emulated in Nav6.  In 
strict mode, it works correctly.  Marked invalid.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → INVALID
(Assignee)

Comment 12

18 years ago
Created attachment 21132 [details]
testcase showing that it works in strict mode
(Reporter)

Comment 13

18 years ago
hmmm... what does it mean "strict" mode ? How should I switch "mozilla"
into "strict" mode ??

Igor
Netscape's standard compliance QA team reorganised itself once again, so taking 
remaining non-tables style bugs. Sorry about the spam. I tried to get this done 
directly at the database level, but apparently that is "not easy because of the 
shadow db", "plus it screws up the audit trail", so no can do...
QA Contact: chrisd → ian
VERIFIED -- this now works correctly in all modes.

To switch to Standard mode, include an HTML 4.0 DOCTYPE in your document.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.