Slow performance on SVG demo "Clip Drag"

RESOLVED WORKSFORME

Status

()

Core
Graphics
RESOLVED WORKSFORME
7 years ago
6 years ago

People

(Reporter: icecold, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; rv:2.0b8pre) Gecko/20101123 Firefox/4.0b8pre
Build Identifier: 

Firefox has a slow performance on Clip Drag demo while Google Chrome 9 or Internet Explorer 9 Platform Preview 7 run demo smoothly. (Opera runs it smoothly too) .

Hardware acceleration is on. (Direct2D and Direct3D 10)


Reproducible: Always

Steps to Reproduce:
1.Go to http://srufaculty.sru.edu/david.dailey/svg/clipdrag12.svg
2.Move your mouse to see performance
3.
Actual Results:  
Demo was slow.

Expected Results:  
It should be smooth.
Works fine here on Mac.  Might be a Windows-only graphics issue....
seems to be fast for me using Mozilla/5.0 (Windows NT 6.1; rv:2.0b8pre) Gecko/20101121 Firefox/4.0b8pre SeaMonkey/2.1b2pre and a NVIDIA GeForce 310M

Comment 3

7 years ago
Works great on W7 with ATI 3870 card (latest nightly)
On WinXP, comparing http://hg.mozilla.org/mozilla-central/rev/4b9ba5049e66 with Google Chrome 9.0.583.0, the Interaction/Movement on GC is smooth, on Fx it's choppy. Worth to note that the Choppyness with Fx does not come from limited CPU Power, since it's below 100% like on GC all the Time.

Adapter Description Radeon X1950 Pro
Vendor ID1002
Device ID7280
Adapter RAM Unknown
Adapter Drivers ati2dvag
Driver Version 8.593.100.0
Driver Date 2-10-2010
Direct2D Enabled false
DirectWrite Enabled false
GPU Accelerated Windows1/1 Direct3D 9

Setting layers.accelerate-none;true makes no Difference.

Comment 5

6 years ago
The demo is smooth on Nightly on Windows 7, with and without hardware acceleration.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.