Back-end isn't telling the front-end about the platform restrictions

VERIFIED FIXED in 5.12.6

Status

P2
normal
VERIFIED FIXED
8 years ago
3 years ago

People

(Reporter: krupa.mozbugs, Assigned: jbalogh)

Tracking

Details

(Whiteboard: [z], URL)

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
Created attachment 492712 [details]
screenshot-headers

firefox 4.0b7 and 3.6.12

steps to reproduce:
1. Load the manage versions page for a platform specific add-on https://addons.allizom.org/z/en-US/developers/addon/255386/versions/121778

2.Try to add another file  supporting a different platform

observed behavior:
File validates with no errors. Upon clicking "Add file", nothing happens. Headers show a 400 bad request for that POST. See screenshot for headers.
(Assignee)

Comment 1

8 years ago
400 means we didn't like something about it (addon or version checks).  You'll have to look at the JSON in the response to see the error.
(Reporter)

Updated

8 years ago
Blocks: 614052

Updated

8 years ago
Assignee: nobody → amckay

Updated

8 years ago
Assignee: amckay → thepotch
Whiteboard: [z] → [z][post-freeze+]
Priority: -- → P2
Whiteboard: [z][post-freeze+] → [z]
Target Milestone: 5.12.4 → 5.12.5
(Assignee)

Comment 2

8 years ago
I'm going to close this bug unless you can repro and show response content.
(Reporter)

Comment 3

8 years ago
Bug 614052 is blocking me from trying to reproduce this bug.

Comment 4

8 years ago
Uploads are working again- yay! can you check this out and see if you can reproduce?
(Reporter)

Comment 5

8 years ago
steps to reproduce:
1. Upload a new file for an add-on version @ https://addons.allizom.org/z/en-US/developers/addon/255402/versions/121799
2. During upload, pick a platform which is already supported.
3. After upload is complete, click "Add"

observed behavior:
400 bad request, since back-end isn't telling the front-end about the platform restrictions
Summary: [Manage Versions page] Valid file uploads fail with 400 bad request error → Back-end isn't telling the front-end about the platform restrictions
Target Milestone: 5.12.5 → 5.12.6
Assignee: thepotch → jbalogh
(Assignee)

Comment 6

8 years ago
http://github.com/jbalogh/zamboni/commit/22503bc
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.