move documents for SDK developers to Internals section

RESOLVED FIXED in 1.0b1

Status

RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: myk, Assigned: wbamberg)

Tracking

unspecified
1.0b1

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
Documents that are intended for the SDK's own developers (i.e. folks hacking on the SDK itself) should be moved to an Internals section of the documentation to make it clear that they are not intended for a general addon developer audience.

The documents to move are:

    Low-Level Module Best Practices
    Chrome Authority/Manifest Generation
    XPI Generation
    the __url__, packaging, and memory explanations in Reference > Globals
(Assignee)

Updated

8 years ago
Assignee: nobody → wbamberg
(Assignee)

Comment 1

8 years ago
Created attachment 493022 [details] [diff] [review]
Patch for bug 614339 and 614340

Note that this patch is supposed to address both 614339 and 614340, since they're quite intertwined. I've created new "Experimental" and "Internals" sections and reorganized them as this defect asks. I've split off some of the globals into a new "Internal Globals" page. I've also split out "Program ID" into its own page so it's easy to reference it from other places, because both the tutorial and the XPI Generation page want to reference it. 

I also noticed and fixed what seems to be a bug in "Programs", where cfx actually generates the program ID when you do "cfx run" not "cfx xpi".


This change can also be found at https://github.com/wbamberg/jetpack-sdk/tree/bug614339 if that makes your life any easier.
Attachment #493022 - Flags: review?(avarma)
(Assignee)

Updated

8 years ago
Duplicate of this bug: 613608
Looks great, I've pushed it here:

https://github.com/mozilla/addon-sdk/commit/28013e9ca3ba66e548ceea84d4426e4f1c87eca6

However, I noticed some errors in it that are either minor or not actually relevant to this bug, and commented on them in a separate branch on my repo:

https://github.com/toolness/jetpack-sdk/commit/28013e9ca3ba66e548ceea84d4426e4f1c87eca6
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED

Updated

8 years ago
Attachment #493022 - Flags: review?(avarma) → review+
(Assignee)

Updated

8 years ago
Duplicate of this bug: 600374
You need to log in before you can comment on or make changes to this bug.