Firefox Sync - Generate Sync Key button missing from dialog

RESOLVED DUPLICATE of bug 601019

Status

Cloud Services
Firefox Sync: UI
--
minor
RESOLVED DUPLICATE of bug 601019
7 years ago
7 years ago

People

(Reporter: juergen.edner, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; de; rv:1.9.2.12) Gecko/20101026 Firefox/3.6.12
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; de; rv:1.9.2.12) Gecko/20101026 Firefox/3.6.12 - Firefox Sync v1.5.1

After selecting the menu item "I'm already having an account", entering user name and password and choosing ""use own server" the "Please Enter Your Sync Key" dialog opens. In this dialog no "Generate Sync Key" button is available to automatically generate a key.

Reproducible: Always

Steps to Reproduce:
1. choose menu item "I'm already having an account"
2. select "use own server" in the server field
3. enter user name and password
3. the "Please Enter Your Sync Key" dialog opens but there's no
   "Generate Sync Key" button to automatically generate a key.
Actual Results:  
No "Generate Sync Key" button available to automatically generate a key.

Expected Results:  
A "Generate Sync Key" button should be available.
If you selected "I already have an account", you should enter the Sync Key that was given to you or that you set when you signed up first.

You can find out what the Sync Key is by going to a computer that's already connected and choosing "My Sync Key" from the Sync options page.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

7 years ago
That's not the solution of the problem. I'm using a local Weave Mini server and wasn't able to use the "Create a new account" menu item to create a new account because 
a) in that dialog it's only allowed to enter an email address as account name and not a "normal" name and
b) it's not possible to enter an URL to a local server because an "invalid server url" error message is shown.
Due to this reasons I had to use the "I Have a Firefox-Sync Account" menu item to initially set-up a new account without being able to grep the sync key from an other computer.
I see, I had not considered the minimal server which does not support account setup through the setup wizard.

IMHO there are two solutions to this problem but none of them are what you suggest (because we don't want to add UI only to accommodate a minimal server implementation):

a) Either make the minimal server do account setup OR (and I like this better) retire the minimal server in favour of the Python server which *does* support account setup through the wizard.

b) What we *should* change in the UI is to make the "I have lost my Sync Key" link always visible, not just when you mistype your Sync Key. See bug 601019. Minimal server users can use this to have a Sync Key generated for them.

Duping to bug 601019.
Resolution: INVALID → DUPLICATE
Duplicate of bug: 601019
You need to log in before you can comment on or make changes to this bug.