static assets (js, css, images) should be pulled from CDN

VERIFIED DUPLICATE of bug 545689

Status

VERIFIED DUPLICATE of bug 545689
8 years ago
6 years ago

People

(Reporter: retornam, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [post redesign], URL)

(Reporter)

Description

8 years ago
Currently  most images on http://nova-stage.mozilla.com are not hosted on a CDN. We need to host images on a CDN like on production before nova is pushed.
Whiteboard: [redesign]
(Reporter)

Updated

8 years ago
Summary: Images on nova-stage should be hosted on CDN before we push to production → Images on nova.stage should be hosted on CDN before we push to production
We probably don't have a prefix set up for testing on nova.stage, so we'll need to set that up before QA can check anything.
Summary: Images on nova.stage should be hosted on CDN before we push to production → static assets (js, css, images) should be pulled from CDN
Can the minified js/css files be included from the CDN too? I presume so:

http://mozcom-cdn.mozilla.net/includes/min/min.css?g=css
(In reply to comment #2)
> Can the minified js/css files be included from the CDN too? I presume so:
> 
> http://mozcom-cdn.mozilla.net/includes/min/min.css?g=css

Yes
The most common includes used on almost all pages are now using the static prefix as of r78030. I can't have anthony completely putting me to shame, so I had to at least do this.
As Alex said, we should setup a subdomain to quickly see which resources are not prefixed. Can someone file a bug about that with IT? (and CC me so I'll know where to do it next time)

Steven, eh eh, thanks :)
(In reply to comment #5)
> As Alex said, we should setup a subdomain to quickly see which resources are
> not prefixed. Can someone file a bug about that with IT? (and CC me so I'll
> know where to do it next time)

bug 614436
OS: Mac OS X → All
Hardware: x86 → All
Ok, stage is setup with the CDN config, this can be tested now
I can't see any /cdn URLs. Is config.inc.php updated?
(Reporter)

Comment 9

8 years ago
I also can't see any CDN urls..
(In reply to comment #9)
> I also can't see any CDN urls..

I can.  On the home page, this is the screenshot URL,
http://nova.stage.mozilla.com/cdn/img/home/screenshot-main-mac.png

notice the "/cdn" in that URL.
(Reporter)

Comment 11

8 years ago
http://nova.stage.mozilla.com/img/firefox/security/background-security.png on the security page   and a couple of other pages are not loading images from the CDN

Updated

8 years ago
Whiteboard: [redesign] → [post redesign]
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 545689
(Reporter)

Updated

8 years ago
Status: RESOLVED → VERIFIED
(Assignee)

Updated

7 years ago
Component: www.mozilla.org/firefox → www.mozilla.org
Product: Websites → Websites
(Assignee)

Updated

6 years ago
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
You need to log in before you can comment on or make changes to this bug.