Import silently fails from Eudora 6.2.4 (Mac) to Eudora OSE 1.0 (Mac).

UNCONFIRMED
Assigned to

Status

Penelope
General
--
major
UNCONFIRMED
7 years ago
7 years ago

People

(Reporter: Destin8, Assigned: Matt Dudziak)

Tracking

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_5_8; en-gb) AppleWebKit/533.19.4 (KHTML, like Gecko) Version/5.0.3 Safari/533.19.4
Build Identifier: 

The importer doesn't import any mailboxes from Eudora 6.2.4 (Mac) to Eudora OSE 1.0 (Mac). It loops through all of my mailboxes and appears to export them all, but when it reaches the last mailbox in the list the importer quits -- with no error message -- and none of my mailboxes appear in Eudora v1.0.

Reproducible: Always

Steps to Reproduce:
1. Install Eudora OSE, and let it import my existing Eudora data.
2.
3.
Actual Results:  
Mailboxes not imported.

Expected Results:  
Mailboxes to be imported.

If there is a way to generate an error/progress log during the import, please provide details and I'll get a log and attach it here.
Assignee: nobody → mozilla-bugs
Component: Migration → General
Product: Thunderbird → Penelope
QA Contact: migration → general

Comment 1

7 years ago
> is a way to generate an error/progress log during the import??

(stolen from Jeff)

instructions: https://wiki.mozilla.org/MailNews:Logging

You want to set the log modules to "import:5".

Attach the log to this bug so we can see what's going on.
(Reporter)

Comment 2

7 years ago
After the last time the import failed I removed all traces of Eudora OSE/Thunderbird that I could find, and so I re-downloaded and installed it today.

I followed the instructions to create the .command file and it opened Eudora OSE via the Terminal. I got the import prompt as part of the first start-up sequence, and tried to set that going, but it crashed Eudora OSE and sent off a report via the built-in crash reporter. (I couldn't work out how to extract the technical details from that to paste here.)

I let the crash reporter re-launch Eudora OSE and then tried to import my old Eudora mail folders via Tools - Import... and then clicked "Mail". (The "Import Everything" option is greyed out.) This then appeared to export all of my mail folders. Once it got to the end of them, I saw the export application bouncing in the dock, so switched to it to see why it needed my attention, at which point the export application quit, without any error messages. Eudora OSE was still open at this point, with the Mailboxes window open and an empty sheet floating above it, with greyed-out "back" and "next" buttons. "Cancel" was clickable, but I left it for a bit in case it was doing something and just not providing a status update. The bottom of the "Mailboxes" window said "Deleted folder Eudora Import".

After a little while I clicked that "Cancel" button. I could see the "Eudora Import" folder in the folder list, even though it claimed to have deleted it, and I could see the settings for my accounts that it had to have got via the import.

I've just quit Eudora OSE and relaunched it, and the "Eudora Import" folder has vanished from the folder list, but the account settings are still present.

I've looked in /Users/shortname/Library/Thunderbird/Profiles/????/Mail/ and there are just empty inbox and trash files there.

The import log file was created, but is empty.
You need to log in before you can comment on or make changes to this bug.