If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

crash if a new tab is created while in empty "group tabs" mode

RESOLVED WORKSFORME

Status

Firefox Graveyard
Panorama
--
critical
RESOLVED WORKSFORME
7 years ago
2 years ago

People

(Reporter: Sam K, Unassigned)

Tracking

Trunk
Firefox 4.0

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-GB; rv:1.9.2.12) Gecko/20101026 Firefox/3.6.12
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b8pre) Gecko/20101124 Firefox/4.0b8pre

Trying to create a new tab while in 'group tabs' mode crashes if it is completely
empty.

Reproducible: Always

Steps to Reproduce:
1. start firefox
2. make sure a single tab exists
3. press "group your tabs" icon
4. close the group, the page should be empty
5. go to firefox menu and select new tab
Actual Results:  
firefox crashes

Expected Results:  
firefox should either close the 'group tab' mode and add an empty tab
or add a new group then an empty tab inside it without changing modes

Updated

7 years ago
Component: Tabbed Browser → TabCandy
QA Contact: tabbed.browser → tabcandy

Comment 1

7 years ago
Regression window(Cached hourly):
Works(Because undo group feature is not implemented yet.Close browser after close all groups immediately):
http://hg.mozilla.org/mozilla-central/rev/5c0a3f26e0ef
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b6pre) Gecko/20100910 Firefox/4.0b6pre ID:20100910082144
Fails:
http://hg.mozilla.org/mozilla-central/rev/e522e8bf3524
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b6pre) Gecko/20100910 Firefox/4.0b6pre ID:20100910100716
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=5c0a3f26e0ef&tochange=e522e8bf3524
Blocks: 587341
blocking2.0: --- → ?
OS: Windows 7 → All
Hardware: x86_64 → All
Target Milestone: --- → Firefox 4.0
Version: unspecified → Trunk
Sam, could you add any crash report links from about:crashes? This could be one of those problems where the application is closing unintentionally, but not crashing.
(Reporter)

Comment 3

7 years ago
Juan,

After some prodding around with a debug build -- I've traced the problem
to a buggy graphics card issue -- firefox requests the window be closed
and the animation request causes the crash and it takes out firefox
(with an app crash).

I updated the graphics card driver yet again and the crash no longer happens
so this bug can be changed to an unexpected behaviour but nothing as serious! :)
If any of those crashes are listed in about:crashes, please post a link. There might be some value in knowing how people could experience crashes, for reference. Thanks for looking into it.

Comment 5

7 years ago
Is this bug still an issue? Is the tab candy component the right place for this; it seems only tangentially related.
Marking confirmed based on Alice's regression range. Can we get a crash stack?
Status: UNCONFIRMED → NEW
blocking2.0: ? → final+
Ever confirmed: true

Comment 7

7 years ago
Crash stack would be very useful.
Also, does this happen on Windows only?

Comment 8

7 years ago
I can not reproduce on latest nightly.
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b9pre) Gecko/20101227 Firefox/4.0b9pre ID:20101227030354

Fixed range:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=822e23ac1f71&tochange=4ca2a5e830ce
Does this bug still exist?
I can not reproduce this either (with trunk).
Sam K, if you could reproduce it and provide a crash stack as requested above, that would be great. Otherwise marking as worksforme, given all the reports.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

2 years ago
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.