Flash text labels not displayed. Flash Settings menu labels also invisible + does not respond to mouse

RESOLVED FIXED

Status

()

Firefox
General
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: DavidC, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; rv:2.0b8pre) Gecko/20101124 Firefox/4.0b8pre
Build Identifier: Mozilla/5.0 (Windows NT 6.1; rv:2.0b8pre) Gecko/20101124 Firefox/4.0b8pre

x + y-axis and graph line labels at specified URL are not displayed. Also, Flash Settings Manager labels are not shown + it does not respond to mouse clicks.

Disabling Options > Advanced > General > Use hardware acceleration when available caused browser to crash (Crash Report sent). On restart, Flash works as expected.

Reproducible: Always

Steps to Reproduce:
1. visit http://www.google.com/publicdata?ds=wb-wdi&ctype=l&strail=false&nselm=h&met_y=sp_pop_grow&scale_y=lin&ind_y=false&rdim=country&idim=country:USA:CHN:IND:DEU:NER&tdim=true&tstart=-315619200000&tunit=Y&tlen=48&hl=en&dl=en

2. right click for Flash Settings Manager
Actual Results:  
1. graph labels are missing - http://i.imgur.com/08TLr.png (same result on clean profile)

2. Flash context menu labels are not displayed, does not respond to mouse clicks - http://i.imgur.com/vG7dn.png

Expected Results:  
Chrome results - http://i.imgur.com/MiV6V.png

nvidia 8800GT card, latest nvidia drivers, latest Flash (also tried latest beta).
I can confirm this.

WITH HW ACC enabled, the labels are not shown. 
WITHOUT HW ACC, the labels are shown.

I guess it's an async plugin-painting bug.

BTW, the Flash settings manager doesn't responde even with HW ACC disabled, that's another bug.
Setting dom.ipc.plugins.enabled to "false" also made the text labels shown.


CCing bsmedberg for feedback.

Comment 3

7 years ago
Issue 1: It seems to duplicate Bug 611635
Issue 2: It seems to duplicate Bug 611635 and Bug 604303
(Reporter)

Comment 4

7 years ago
This bug has been fixed with Bug 611635 and Bug 604303.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.