[traceback] OSError: [Errno 13] Permission denied: '/data/amo_python/www/preview/zamboni/tmp'

VERIFIED DUPLICATE of bug 614697

Status

addons.mozilla.org Graveyard
Developer Pages
--
major
VERIFIED DUPLICATE of bug 614697
8 years ago
2 years ago

People

(Reporter: krupa, Unassigned)

Tracking

Details

(Whiteboard: [z], URL)

(Reporter)

Description

8 years ago
steps to reproduce:
1. Load https://addons.allizom.org/z/en-US/developers/addon/submit/1
2. Upload a valid xpi file
3. Click "Continue"

traceback:
 File "/data/amo_python/www/preview/zamboni/apps/amo/decorators.py", line 24, in wrapper
   return func(request, *args, **kw)

 File "/data/amo_python/www/preview/zamboni/apps/devhub/views.py", line 622, in wrapper
   return f(request, *args, **kw)

 File "/data/amo_python/www/preview/zamboni/apps/devhub/views.py", line 658, in submit_addon
   if form.is_valid():

 File "/data/amo_python/www/preview/zamboni/vendor/src/django/django/forms/forms.py", line 121, in is_valid
   return self.is_bound and not bool(self.errors)

 File "/data/amo_python/www/preview/zamboni/vendor/src/django/django/forms/forms.py", line 112, in _get_errors
   self.full_clean()

 File "/data/amo_python/www/preview/zamboni/vendor/src/django/django/forms/forms.py", line 268, in full_clean
   self._clean_form()

 File "/data/amo_python/www/preview/zamboni/vendor/src/django/django/forms/forms.py", line 296, in _clean_form
   self.cleaned_data = self.clean()

 File "/data/amo_python/www/preview/zamboni/apps/devhub/forms.py", line 326, in clean
   xpi = parse_xpi(self.cleaned_data['upload'].path)

 File "/data/amo_python/www/preview/zamboni/apps/files/utils.py", line 64, in parse_xpi
   os.makedirs(path)

 File "/usr/lib/python2.6/os.py", line 150, in makedirs
   makedirs(head, mode)

 File "/usr/lib/python2.6/os.py", line 157, in makedirs
   mkdir(name, mode)

OSError: [Errno 13] Permission denied: '/data/amo_python/www/preview/zamboni/tmp'


<WSGIRequest
GET:<QueryDict: {}>,
POST:<QueryDict: {u'platform': [u'2'], u'csrfmiddlewaretoken': [u'624f0c053c4e9d71c86e978497a5a446'], u'upload': [u'84f3f671cc6f4245aef0ca0bcb6f5e7d']}>,
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 614697
(Reporter)

Comment 2

8 years ago
verified dupe
Status: RESOLVED → VERIFIED
(Assignee)

Updated

2 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.