Add/fix paths to /tmp, for AMO (Zamboni/preview)

VERIFIED FIXED

Status

mozilla.org Graveyard
Server Operations
VERIFIED FIXED
7 years ago
3 years ago

People

(Reporter: stephend, Assigned: oremj)

Tracking

Details

(URL)

(Reporter)

Description

7 years ago
https://addons.allizom.org/services/monitor currently has a few errors/warnings:

/data/amo_python/www/preview/zamboni/tmp
    Does not exist and does not have the permissions we expect. (We want read + write.) 

/data/amo_python/www/preview/zamboni/tmp/data/sphinx
    Does not exist and does not have the permissions we expect. (We want read + write.) 
/data/amo_python/www/preview/zamboni/tmp/log/searchd
    Does not exist and does not have the permissions we expect. (We want read + write.)
(Assignee)

Comment 1

7 years ago
How tmp are these? Can each server have its own copy or do they need to share? Why are we logging to disk?
/tmp needs to be shared, it's where we extract uploads.

The other two directories aren't used at all in production, they are just a part of monitor for people who set up zamboni for development and don't change file paths.
Duplicate of this bug: 614676

Updated

7 years ago
Assignee: server-ops → jeremy.orem+bugs
We need to add this to settings_local.py under the definition of TMP_PATH:

SPHINX_CATALOG_PATH = TMP_PATH + '/data/sphinx'
SPHINX_LOG_PATH = TMP_PATH + '/log/searchd'
(Assignee)

Comment 5

7 years ago
Done.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
(Reporter)

Comment 6

7 years ago
Verified FIXED on https://addons.allizom.org/services/monitor.
Status: RESOLVED → VERIFIED
Product: mozilla.org → mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.