Crash [@ nsQueryInterface::operator() ]

RESOLVED DUPLICATE of bug 612383

Status

Fennec Graveyard
General
--
critical
RESOLVED DUPLICATE of bug 612383
7 years ago
4 years ago

People

(Reporter: nhirata, Unassigned)

Tracking

Trunk
ARM
Android

Details

Mozilla/5.0 (Android; Linux armv71; rv2.0b8pre) Gecko/20101124 Firefox/4.0b8pre Fennec/4.0b3pre

Not completely sure how I got this crash.  The following are the conditions that I do remember having:

1) installed arabic plugin : http://ftp.mozilla.org/pub/mozilla.org/mobile/nightly/latest-mozilla-central-maemo5-gtk-l10n/fennec-4.0b3pre.ar.langpack.xpi
2) had 7 tabs open
3) was in arabic for language
4) was in the addon section doing a query for "nightly tester"
5) was using hardware keyboard
6) had simeji IME

http://crash-stats.mozilla.com/report/index/bp-e56fee5e-ff8a-474c-af66-0423c2101124

Source
0 	libxul.so 	nsQueryInterface::operator 	nsCOMPtr.cpp:47
1 	libxul.so 	nsCOMPtr_base::assign_from_qi 	nsCOMPtr.cpp:96
2 	libxul.so 	mozilla::dom::TabParent::GetWidget 	nsCOMPtr.h:800
3 	libxul.so 	mozilla::dom::TabParent::HandleQueryContentEvent 	nsCOMPtr.h:443
4 	libxul.so 	nsEventStateManager::RemoteQueryContentEvent 	content/events/src/nsEventStateManager.cpp:3316
5 	libxul.so 	nsEventStateManager::PreHandleEvent 	content/events/src/nsEventStateManager.cpp:1348
6 	libxul.so 	PresShell::HandleEventInternal 	layout/base/nsPresShell.cpp:6945
7 	libxul.so 	PresShell::HandleEvent 	layout/base/nsPresShell.cpp:6709
8 	libxul.so 	nsViewManager::HandleEvent 	view/src/nsViewManager.cpp:1095
9 	libxul.so 	nsViewManager::DispatchEvent 	view/src/nsViewManager.cpp:1070
10 	libxul.so 	HandleEvent 	nsCOMPtr.h:492
11 	libxul.so 	nsWindow::DispatchEvent 	widget/src/android/nsWindow.cpp:582
12 	libxul.so 	nsWindow::OnIMEEvent 	widget/src/android/nsWindow.cpp:1533
13 	libxul.so 	nsWindow::OnGlobalAndroidEvent 	widget/src/android/nsWindow.cpp:757
14 	libxul.so 	nsAppShell::ProcessNextNativeEvent 	widget/src/android/nsAppShell.cpp:293
15 	libxul.so 	nsBaseAppShell::DoProcessNextNativeEvent 	widget/src/xpwidgets/nsBaseAppShell.cpp:163
16 	libxul.so 	nsBaseAppShell::OnProcessNextEvent 	widget/src/xpwidgets/nsBaseAppShell.cpp:309
17 	libxul.so 	mozilla::dom::ContentParent::OnProcessNextEvent 	dom/ipc/ContentParent.cpp:598
18 	libxul.so 	nsThread::ProcessNextEvent 	nsTArray.h:135
19 	libxul.so 	NS_ProcessNextEvent_P 	nsThreadUtils.cpp:250
20 	libxul.so 	nsXMLHttpRequest::Send 	content/base/src/nsXMLHttpRequest.cpp:2683
21 	libxul.so 	nsIXMLHttpRequest_Send 	dom_quickstubs.cpp:25494
22 	libxul.so 	js::Interpret 	js/src/jsinterp.cpp:4750
23 	libxul.so 	js::Invoke 	js/src/jsinterp.cpp:657
24 	libxul.so 	js::ExternalInvoke 	js/src/jsinterp.cpp:858
25 	libxul.so 	JS_CallFunctionValue 	js/src/jsinterp.h:962
26 	libxul.so 	nsXPCWrappedJSClass::CallMethod 	js/src/xpconnect/src/xpcwrappedjsclass.cpp:1696
27 	libxul.so 	nsXPCWrappedJS::CallMethod 	js/src/xpconnect/src/xpcwrappedjs.cpp:589
28 	libxul.so 	PrepareAndDispatch 	xpcom/reflect/xptcall/src/md/unix/xptcstubs_arm.cpp:134
29 	libxul.so 	libxul.so@0x94f84c 	
30 	libxul.so 	nsDocument::InitCSP 	content/base/src/nsDocument.cpp:2429
31 		@0x4a4d2687 	
32 	libxul.so 	nsDocument::StartDocumentLoad 	content/base/src/nsDocument.cpp:2367
33 	libxul.so 	nsXMLDocument::StartDocumentLoad 	content/xml/document/src/nsXMLDocument.cpp:517
34 	libxul.so 	nsXMLHttpRequest::OnStartRequest 	content/base/src/nsXMLHttpRequest.cpp:2045
35 	libxul.so 	nsHttpChannel::CallOnStartRequest 	netwerk/protocol/http/nsHttpChannel.cpp:771
36 	libxul.so 	nsHttpChannel::ContinueProcessNormal 	netwerk/protocol/http/nsHttpChannel.cpp:1229
37 	libxul.so 	nsHttpChannel::ProcessNormal 	netwerk/protocol/http/nsHttpChannel.cpp:1166
38 	libxul.so 	nsHttpChannel::ProcessResponse 	netwerk/protocol/http/nsHttpChannel.cpp:1115
39 	libxul.so 	nsHttpChannel::OnStartRequest 	netwerk/protocol/http/nsHttpChannel.cpp:3805
40 	libxul.so 	nsInputStreamPump::OnStateStart 	netwerk/base/src/nsInputStreamPump.cpp:445
41 	libxul.so 	nsInputStreamPump::OnInputStreamReady 	netwerk/base/src/nsInputStreamPump.cpp:397
42 	libxul.so 	nsInputStreamReadyEvent::Run 	nsCOMPtr.h:663
43 	libxul.so 	nsThread::ProcessNextEvent 	xpcom/threads/nsThread.cpp:626
44 	libxul.so 	NS_ProcessNextEvent_P 	nsThreadUtils.cpp:250
45 	libxul.so 	mozilla::ipc::MessagePump::Run 	ipc/glue/MessagePump.cpp:134
46 	libxul.so 	MessageLoop::RunInternal 	ipc/chromium/src/base/message_loop.cc:220
47 	libxul.so 	MessageLoop::Run 	ipc/chromium/src/base/message_loop.cc:512
48 	libxul.so 	nsBaseAppShell::Run 	widget/src/xpwidgets/nsBaseAppShell.cpp:187
49 	libxul.so 	nsAppStartup::Run 	toolkit/components/startup/src/nsAppStartup.cpp:192
50 	libxul.so 	XRE_main 	toolkit/xre/nsAppRunner.cpp:3693
51 	libxul.so 	GeckoStart 	toolkit/xre/nsAndroidStartup.cpp:131
52 	libc.so 	libc.so@0x10f27 	
53 	libc.so 	libc.so@0x10a13

Updated

7 years ago
tracking-fennec: --- → ?

Updated

7 years ago
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 612383
(Assignee)

Updated

4 years ago
tracking-fennec: ? → ---
You need to log in before you can comment on or make changes to this bug.