Closed Bug 614726 Opened 9 years ago Closed 4 years ago

reorganize moveTabToGroupItem, give it consistent behavior with removeTab

Categories

(Firefox Graveyard :: Panorama, defect, P4)

defect

Tracking

(Not tracked)

RESOLVED WONTFIX
Future

People

(Reporter: tabutils+bugzilla, Unassigned)

References

Details

User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:2.0b8pre) Gecko/20101124 Firefox/4.0b8pre
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0b8pre) Gecko/20101124 Firefox/4.0b8pre

Handle tab.owner (bug 608184) and tabbrowser._lastRelatedTab, call tabbrowser._blurTab instead of tabbrowser.selectTabAtIndex, update first-tab/last-tab/beforeselected/afterselected attributes, etc. And maybe need animation? 
Everything which is done in gBrowser.removeTab should be considered carefully.

Reproducible: Always
Blocks: 597043
Version: unspecified → Trunk
Blocks: 608184
Something done in gBrowser.moveTabTo should also be considered, such as ensureElementIsVisible.
Is this just for code cleanliness purposes? Or are you asking for a functional change?

Raymond did you make these changes in tabbrowser? Can you investigate?
Assignee: nobody → raymond
Priority: -- → P4
This is requesting moveTabToGroupItem to have its behavior fixed like removeTab (from the tab bar). I'm not sure whether this is a functional change.
See patch for bug 608184, I think it fixes this as well.
(In reply to comment #4)
> See patch for bug 608184, I think it fixes this as well.

tab.owner issue seems correctly handled. Other issues should remain.
bug spam (moving to b10)
Blocks: 608028
bug spam
No longer blocks: 597043
Punting
No longer blocks: 608028, 608184
Status: UNCONFIRMED → NEW
Depends on: 608184
Ever confirmed: true
Target Milestone: --- → Future
Depends on: 650010
bugspam

(Fx7 was branched, removing open bugs from Fx7 meta bug, we won't create new meta bugs for upcoming Fx versions)
No longer blocks: 660175
Assignee: raymond → nobody
Panorama has been removed from Firefox 45, currently in Beta and scheduled for release on March 7th. As such, I'm closing all existing Panorama bugs.

If you are still using Panorama, you will see a deprecation message in Firefox 44, and when 45 is released your tab group data will be migrated to bookmarks, with a folder for each group. There are also a few addons offering similar functionality.

See https://support.mozilla.org/en-US/kb/tab-groups-removal for more info.

We're removing Panorama because it has extremely low usage (about 0.01% of users), and has a large number of bugs and usability issues. The cost of fixing all those issues is far too high to justify, and so we'll instead be focusing our time and energy on improving other parts of Firefox.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WONTFIX
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.