The menu item |Tasks|Tools|Java Console| does not indicate the absence of the Java plug-in or JRE access.

VERIFIED DUPLICATE of bug 61474

Status

P3
normal
VERIFIED DUPLICATE of bug 61474
18 years ago
8 years ago

People

(Reporter: LlelanD, Assigned: edburns)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; m18) Gecko/20001127
BuildID:    2000112720

Build ID: 2000112720
 on  Win2Kpro 5.00.2195 SP1 IE5.5,
 and WinMe    4.90.3000     IE5.5

There is no indication as to whether the Java plug-in is installed. The menu item
   |Tasks|Tools|Java Console|
is NOT disabled when the plug-in is not installed. When it is chosen, nothing
happens.

As there is no documentation or instruction available to a user, no hint that a
plug-in is needed for an Applet to access Java, and given that all browsers in
the past have installed their own JVM which gave automatic access to Java, the
user is left with no idea as to what could be wrong or what to do about it.

Two solutions are needed.
  1. All UI functions which depend on an installed component must visually
indicate that the function is unavailable if the component is absent.
  2. The release notes available from the |Help|Release Notes| menu item for
each release must contain a list of the optional components that are not
installed by default, what browser functions they affect or enable, and
instructions and/or links as to how to install them.

A better remedy:
  My preferred solution to this type of situation is to design the UI with a
proactive stance and not depend on the documentation. For menu items I define a
visual state seperate from disabled to indicate that the function would be
available but for a missing component. The visual cue I use is to display the
menu item as enabled and stricken (with the font attribute "strike-through"
which adds a horizontal line through each letter). The menu item also displays a
tooltip to indicate the missing component (An MSWindows thing, the status bar
might be used if a tooltip system is not available). If the menu item is chosen,
a dialog box comes up describing the missing component(s) and providing a link
or button to an installation instruction or process for the missing component(s).

  This allows your UI to still work clearly, independent of any missing
documentation, but it should never be seen as an excuse to lower the priority of
or not provide the related documentation. I submitted this bug after being
verbally backhanded when I misinterpreted it in a related bug report as a Java
Console failure in the presence of a working Java environment since I had no
idea, reference, or indication that a plug-in was needed or missing. I only
managed to finally confirm the true source of this problem through a third-party
FAQ via a general web search.


Reproducible: Always
Steps to Reproduce:
Close all the instances of the Mozilla browser. Remove the Java plug-in DLLs
(like npjava11.dll, npjava12.dll, and npjava3s.dll) from the installation
"plugins" directory (typically "c:\Program Files\Mozilla\Seamonkey\plugins").
Start a new browser instance. Note the state of the |Tasks|Tools|Java Console|
menu item.

Actual Results:  The menu item |Tasks|Tools|Java Console| is still normally
enabled. When you choose it, nothing happens. In the absense of any related
documentation in the release notes, the user is left with no clue as to what is
wrong.

Expected Results:  At the very least, any UI function disabled by the lack of an
optionally installed component or a failed or disabled component should be
visually indicated. Optional components, their default state, and access and
installation instructions should be present in a file available from the Help
menu, such as the release notes.

Comment 1

18 years ago

*** This bug has been marked as a duplicate of 61474 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 2

18 years ago
verified dup
Status: RESOLVED → VERIFIED

Updated

8 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.