Themes are breaking web console's UI

RESOLVED WORKSFORME

Status

()

Firefox
Developer Tools
RESOLVED WORKSFORME
7 years ago
6 years ago

People

(Reporter: Andreea Pod, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [console-3], URL)

Attachments

(2 attachments)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; rv:2.0b8pre) Gecko/20101124 Firefox/4.0b8pre
Build Identifier: Mozilla/5.0 (Windows NT 6.1; rv:2.0b8pre) Gecko/20101124 Firefox/4.0b8pre

Web console is customized when using themes. When a custom theme is installed, from AMO for e.g., the console inherits layout elements and it's UI is busted. 

Console's UI should not be affected by themes. 

Reproducible: Always

Steps to Reproduce:
1.Install a theme from https://addons.mozilla.org/en-US/firefox/themes/
2.Open web console

Actual Results:  
The theme is customizing the web console. 

Expected Results:  
Web console should be the same as before installing any theme.

Checked this within a clean profile, with multiple themes installed and both with only the default and one custom install. 

This is reproducible regardless of which theme is installed. 

Note: see screenshots
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 1

7 years ago
Created attachment 493231 [details]
Web console with Office Black Theme
(Reporter)

Comment 2

7 years ago
Created attachment 493232 [details]
Web console with LavaFox Theme
see also, bug 601196.

I expect there are some differences between the way we're broken with LightWeightThemes and full browser Themes, so keeping these separate for now.
Summary: Themes are braking web console's UI → Themes are breaking web console's UI

Comment 4

7 years ago
Since the Web Console is part of the Chrome UI, I would think that it was the responsibility of Theme developers to style the Web Console appropriately, the way they theme the Addons Manager tab, Download Manager, etc.
it's true, but it'd be nice if the web console didn't completely break with a third-party incomplete theme installed.

Comment 6

7 years ago
It's possible that Patrick's styling work may fix the problems exhibited here.
Assignee: nobody → pwalton
Priority: -- → P1
(In reply to comment #6)
> It's possible that Patrick's styling work may fix the problems exhibited here.

I'm not sure, actually.

I'm less concerned about the themes - as Philip mentions above, themes can style the Web Console manually as part of Firefox 4 compatibility - but I am concerned about Personas.

Updated

7 years ago
OS: Windows 7 → All
Priority: P1 → --
I don't see problems with personas anymore on 

Mozilla/5.0 (Windows NT 6.1; rv:2.0b9pre) Gecko/20110102 Firefox/4.0b9pre

Still, installing for e.g. https://addons.mozilla.org/en-US/firefox/addon/8076/ 
puts the console in an unclosable state. 
Behaviors are different from one theme to another.

Updated

7 years ago
Whiteboard: [console-3]

Updated

7 years ago
Assignee: pwalton → nobody

Comment 9

6 years ago
Should this be closed on the basis of comment 4?
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.