crash [@ arena_dalloc | free | nsAutoArrayPtr<gfxTextRun::DetailedGlyph>::~nsAutoArrayPtr<gfxTextRun::DetailedGlyph>() ]

RESOLVED WORKSFORME

Status

()

Core
Graphics
--
critical
RESOLVED WORKSFORME
8 years ago
7 years ago

People

(Reporter: Scoobidiver (away), Unassigned)

Tracking

({crash, regression})

Trunk
x86
Windows 7
crash, regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

8 years ago
It is a new crash signature that exists in 4.0b6, b7 and b8pre builds.
From 4.0b8pre/20101122 build, there is a spike in crashes.
It is #41 top crasher in 4.0b8pre for the last 3 days.

Signature	arena_dalloc | free | nsAutoArrayPtr<gfxTextRun::DetailedGlyph>::~nsAutoArrayPtr<gfxTextRun::DetailedGlyph>()
UUID	941e73da-18ad-4979-b636-789412101125
Time 	2010-11-25 21:20:48.844861
Uptime	44
Last Crash	47 seconds before submission
Install Age	4987 seconds (1.4 hours) since version was first installed.
Product	Firefox
Version	4.0b8pre
Build ID	20101125030318
Branch	2.0
OS	Windows NT
OS Version	6.1.7600
CPU	x86
CPU Info	GenuineIntel family 6 model 37 stepping 2
Crash Reason	EXCEPTION_ACCESS_VIOLATION_READ
Crash Address	0x0
App Notes 	AdapterVendorID: 10de, AdapterDeviceID: 06cd
MSAFD Tcpip [TCP/IP] : 2 : 1 :
MSAFD Tcpip [UDP/IP] : 2 : 2 : %SystemRoot%\system32\mswsock.dll
MSAFD Tcpip [RAW/IP] : 2 : 3 :
MSAFD Tcpip [TCP/IPv6] : 2 : 1 : %SystemRoot%\system32\mswsock.dll
MSAFD Tcpip [UDP/IPv6] : 2 : 2 :
MSAFD Tcpip [RAW/IPv6] : 2 : 3 : %SystemRoot%\system32\mswsock.dll
RSVP TCPv6 Service Provider : 2 : 1 :
RSVP TCP Service Provider : 2 : 1 : %SystemRoot%\system32\mswsock.dll
RSVP UDPv6 Service Provider : 2 : 2 :
RSVP UDP Service Provider : 2 : 2 : %SystemRoot%\system32\mswsock.dll

Frame 	Module 	Signature [Expand] 	Source
0 	mozcrt19.dll 	arena_dalloc 	obj-firefox/memory/jemalloc/crtsrc/jemalloc.c:4275
1 	mozcrt19.dll 	free 	obj-firefox/memory/jemalloc/crtsrc/jemalloc.c:6121
2 	xul.dll 	nsAutoArrayPtr<gfxTextRun::DetailedGlyph>::~nsAutoArrayPtr<gfxTextRun::DetailedGlyph> 	obj-firefox/dist/include/nsAutoPtr.h:537
3 	xul.dll 	`vector destructor iterator' 	
4 	mozalloc.dll 	mozalloc.dll@0x106f 	
5 	xul.dll 	nsExpirationTracker<gfxTextRun,3>::TimerCallback 	obj-firefox/dist/include/nsExpirationTracker.h:307
6 	xul.dll 	nsTimerImpl::Fire 	xpcom/threads/nsTimerImpl.cpp:425
7 	xul.dll 	nsTimerEvent::Run 	xpcom/threads/nsTimerImpl.cpp:517
8 	xul.dll 	nsThread::ProcessNextEvent 	xpcom/threads/nsThread.cpp:626
9 	xul.dll 	mozilla::ipc::MessagePump::Run 	ipc/glue/MessagePump.cpp:110
10 	xul.dll 	xul.dll@0xb0bcbb 	
11 	xul.dll 	MessageLoop::RunHandler 	ipc/chromium/src/base/message_loop.cc:202
12 	mozcrt19.dll 	_VEC_memzero 	
13 	xul.dll 	xul.dll@0x35996d 	
14 	firefox.exe 	firefox.exe@0x1bb7 	
15 	ntdll.dll 	WinSqmSetIfMaxDWORD 	
16 	ntdll.dll 	_RtlUserThreadStart 	
17 	firefox.exe 	firefox.exe@0x186f 	
18 	firefox.exe 	firefox.exe@0x186f

The regression range for the spike is:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=be4b69a4babf&tochange=4d73807bfec7

More reports at:
http://crash-stats.mozilla.com/report/list?product=Firefox&query_search=signature&query_type=exact&query=&range_value=4&range_unit=weeks&hang_type=any&process_type=any&plugin_field=&plugin_query_type=&plugin_query=&do_query=1&admin=&signature=arena_dalloc%20|%20free%20|%20nsAutoArrayPtr%3CgfxTextRun%3A%3ADetailedGlyph%3E%3A%3A~nsAutoArrayPtr%3CgfxTextRun%3A%3ADetailedGlyph%3E%28%29
(Assignee)

Updated

7 years ago
Crash Signature: [@ arena_dalloc | free | nsAutoArrayPtr<gfxTextRun::DetailedGlyph>::~nsAutoArrayPtr<gfxTextRun::DetailedGlyph>() ]
Looks like this went away after 4.0b8, according to the crash reports.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
(Reporter)

Updated

7 years ago
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.