If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

crash [@ JSStackFrame::scopeChain() ]

RESOLVED WORKSFORME

Status

()

Core
JavaScript Engine
--
critical
RESOLVED WORKSFORME
7 years ago
6 years ago

People

(Reporter: Scoobidiver (away), Unassigned)

Tracking

({crash, regression})

Trunk
x86
Windows XP
crash, regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

7 years ago
It is a new crash signature that exists in 4.0b7 and 4.0b8pre builds.
It is #227 top crasher inn 4.0b7 for the last week.

Comments say:
"tried opening a file from Outlook Live: Skydrive in Word. Browser crashed."
"Where are now the last update of firefox Occurred of öffters, usually when I have a player with an open page such as YouTube and then I also go to other pages by taps" in German

Signature	JSStackFrame::scopeChain()
UUID	df6712c1-a2b1-4cf5-bd69-1c3b02101125
Time 	2010-11-25 19:38:48.454831
Uptime	328
Last Crash	772 seconds (12.9 minutes) before submission
Install Age	1746 seconds (29.1 minutes) since version was first installed.
Product	Firefox
Version	4.0b8pre
Build ID	20101125030318
Branch	2.0
OS	Windows NT
OS Version	5.1.2600 Service Pack 3
CPU	x86
CPU Info	AuthenticAMD family 16 model 4 stepping 3
Crash Reason	EXCEPTION_ACCESS_VIOLATION_READ
Crash Address	0x3e02203a
App Notes 	AdapterVendorID: 1002, AdapterDeviceID: 9611
MSAFD Tcpip [TCP/IP] : 2 : 1 :
MSAFD Tcpip [UDP/IP] : 2 : 2 : %SystemRoot%\system32\mswsock.dll
MSAFD Tcpip [RAW/IP] : 2 : 3 : %SystemRoot%\system32\mswsock.dll
RSVP UDP Service Provider : 6 : 2 : %SystemRoot%\system32\rsvpsp.dll
RSVP TCP Service Provider : 6 : 1 : %SystemRoot%\system32\rsvpsp.dll
MSAFD NetBIOS [\Device\NetBT_Tcpip_{6520EE66-821B-40F1-9681-D1A29791E0B5}] SEQPACKET 3 : 2 : 5 : %SystemRoot%\system32\mswsock.dll
MSAFD NetBIOS [\Device\NetBT_Tcpip_{6520EE66-821B-40F1-9681-D1A29791E0B5}] DATAGRAM 3 : 2 : 2 : %SystemRoot%\system32\mswsock.dll
MSAFD NetBIOS [\Device\NetBT_Tcpip_{21A27678-15A8-48B0-95F8-AE2325D894B2}] SEQPACKET 0 : 2 : 5 : %SystemRoot%\system32\mswsock.dll
MSAFD NetBIOS [\Device\NetBT_Tcpip_{21A27678-15A8-48B0-95F8-AE2325D894B2}] DATAGRAM 0 : 2 : 2 : %SystemRoot%\system32\mswsock.dll
MSAFD NetBIOS [\Device\NetBT_Tcpip_{EA8B16B0-E465-4655-8807-C780AF764F4E}] SEQPACKET 1 : 2 : 5 : %SystemRoot%\syste

Frame 	Module 	Signature [Expand] 	Source
0 	mozjs.dll 	JSStackFrame::scopeChain 	js/src/jsinterp.h:488
1 	mozjs.dll 	RunTracer 	js/src/methodjit/InvokeHelpers.cpp:970
2 	mozjs.dll 	js::mjit::stubs::InvokeTracer 	js/src/methodjit/InvokeHelpers.cpp:1074
3 	mozjs.dll 	js::mjit::EnterMethodJIT 	js/src/methodjit/MethodJIT.cpp:745
4 	mozjs.dll 	CheckStackAndEnterMethodJIT 	js/src/methodjit/MethodJIT.cpp:770
5 	mozjs.dll 	js::mjit::JaegerShot 	js/src/methodjit/MethodJIT.cpp:787
6 	mozjs.dll 	js::RunScript 	js/src/jsinterp.cpp:654
7 	mozjs.dll 	js::Invoke 	js/src/jsinterp.cpp:737
8 	mozjs.dll 	js::ExternalInvoke 	js/src/jsinterp.cpp:858
9 	mozjs.dll 	JS_CallFunctionValue 	js/src/jsapi.cpp:4973
10 	xul.dll 	nsXPCWrappedJSClass::CallMethod 	js/src/xpconnect/src/xpcwrappedjsclass.cpp:1694
11 	xul.dll 	nsXPCWrappedJS::CallMethod 	js/src/xpconnect/src/xpcwrappedjs.cpp:588
12 	xul.dll 	PrepareAndDispatch 	xpcom/reflect/xptcall/src/md/win32/xptcstubs.cpp:114
13 	xul.dll 	SharedStub 	xpcom/reflect/xptcall/src/md/win32/xptcstubs.cpp:141
14 	xul.dll 	nsEventListenerManager::HandleEventSubType 	content/events/src/nsEventListenerManager.cpp:1114

More reports at:
http://crash-stats.mozilla.com/report/list?product=Firefox&query_search=signature&query_type=exact&query=&range_value=4&range_unit=weeks&hang_type=any&process_type=any&plugin_field=&plugin_query_type=&plugin_query=&do_query=1&admin=&signature=JSStackFrame%3A%3AscopeChain%28%29

Comment 1

7 years ago
This currently holds a pretty stable position somewhere between #150 and #200 on the topcrash list for 4.0 with 20-25 crashes per million ADU.
Duplicate of this bug: 650486
Duplicate of this bug: 647546
Crash Signature: [@ JSStackFrame::scopeChain() ]
(Reporter)

Comment 4

6 years ago
There have been no crashes in versions above 5.0.1 for the last four weeks.
I close it as WFM.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME

Updated

6 years ago
Duplicate of this bug: 712248
Duplicate of this bug: 712248
The reporter of bug 712248 still crashes with recent Firefox versions
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---

Comment 8

6 years ago
Excuse me, here is a new details: this bug will be appear only if you right-click two times.

See my videos
http://www.youtube.com/watch?v=L4n-0RMSrio (Firefox 8.0.1)
http://www.youtube.com/watch?v=AXumhq8LLDw (Firefox 9.0, after update)

OS: Windows 7 Ultimate x32 (Russian)
Hardware: intel core i3, 4gb memory, radeon HD5770 video card.
(Reporter)

Comment 9

6 years ago
I confirm there have been no crashes in versions above 5.0.1 for the last four weeks:
https://crash-stats.mozilla.com/report/list?product=Firefox&query_search=signature&query_type=contains&query=JSStackFrame%3A%3AscopeChain&reason_type=contains&range_value=1&range_unit=weeks&hang_type=any&process_type=any&do_query=1&signature=JSStackFrame%3A%3AscopeChain%28%29
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.