Closed Bug 614964 Opened 9 years ago Closed 9 years ago

The browser puts itself into offline mode after a period of idle time and crashes on quit

Categories

(Firefox :: General, defect, critical)

x86_64
macOS
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 614958

People

(Reporter: Panajev, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b8pre) Gecko/20101125 Firefox/4.0b8pre
Build Identifier: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b8pre) Gecko/20101125 Firefox/4.0b8pre

Basically, sometimes it happens that Firefox will not be able to browse new websites (not cached ones) or reload some pages that trigger a new connection attempt and the browser will say that it finds itself to be in Offline Mode.
I think that pre-existing HTTP connections are unaffected as this problem occurred to me the other day when I was performing a download and even though the download continued and completed successfully I could not load a new website in that same period of time (i.e. make new HTTP connections with Firefox... other browsers could browse the web just fine). 

If I try to quit the Firefox browser (saving the data) the browser will just sit there in the Dock idle (light under the browser icon) and I will have to Force Quit the app.

Reproducible: Sometimes

Steps to Reproduce:
1. Use the browser...
2. Maybe put the computer into sleep... or just wait a while...
3. Wake the computer up...
Actual Results:  
Pre-existing download continued to happen... the browser could not open new website though.

Expected Results:  
Browser should operate normally.
I also see this problem.  Firefox gets somehow stuck in offline mode, and on attempting to quit it hangs.

I'm also using a mac.  This problem first started happening for me sometime in the last week or so.  If it's relevant I'm connecting to the net by tethering my phone.  (So the connection is through an ad-hoc wireless network.)


Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b8pre) Gecko/20101125 Firefox/4.0b8pre
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 614872
Duplicate of bug: 614958
You need to log in before you can comment on or make changes to this bug.