[non-nightly/non-release builds] Use ldap c-sdk version 'default' instead of 'LDAPCSDK_6_0_6D_MOZILLA_RTM'

RESOLVED WONTFIX

Status

MailNews Core
Build Config
RESOLVED WONTFIX
8 years ago
8 years ago

People

(Reporter: sgautherie, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
1)
After moving to Hg, I expect ldap (c-sdk) bug activity will raise (somewhat).
I think we should build and test new changesets asap,
yet continue to use a release tag for nightlies and releases.

2)
I'm already wondering about newer
http://hg.mozilla.org/projects/ldap-sdks/rev/88ecbb2a0dd0
"Reland "added support for MozillaBuild using msys""
Should we build this (added) changeset on Windows (at least) ?
Maybe even for nightlies and releases ?
(Reporter)

Updated

8 years ago
Summary: [non-nightly/non-realease builds] Use ldap c-sdk version 'default' instead of 'LDAPCSDK_6_0_6D_MOZILLA_RTM' → [non-nightly/non-release builds] Use ldap c-sdk version 'default' instead of 'LDAPCSDK_6_0_6D_MOZILLA_RTM'
I don't like this idea. Firstly, we should be discussing on tb-planning or the newsgroups before raising a bug.

We should only be building what we release in nightlies. If we're building one thing with tests and another with something else.

Also this would be a configuration nightmare, as what would/should developers actually get - if they go default, then some stuff could be broken in nightlies that devs wouldn't see, if they got branch, then tests or other build stuff could break and they wouldn't necessarily realise what they needed to test.

I treat LDAP c-sdk as a third party library, where we import when we're ready to. I don't see a reason to treat it differently just because it is in the same repository space.

If we want to treat it differently, then we should pull default and tag for releases, however there's so little activity there that I don't see much point in doing that.

FTR I know that revision you quoted is actually broken and there's already a bug on it, once I've got that resolved, the plan was to update to latest c-sdk code anyway.
I've not heard any objections to my comments so I'm closing this as wontfix. If we want to change that decision then we should discuss ton the appropriate lists.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.