Closed Bug 614983 Opened 11 years ago Closed 11 years ago

In the updated add-on manager, icons for disabled add-ons are missing

Categories

(Toolkit :: Add-ons Manager, defect)

defect
Not set
minor

Tracking

()

VERIFIED DUPLICATE of bug 611241
Tracking Status
blocking2.0 --- betaN+

People

(Reporter: sdrocking, Unassigned)

References

Details

(Keywords: regression, Whiteboard: [needs 611241])

User-Agent:       Mozilla/5.0 (Windows NT 6.1; rv:2.0b8pre) Gecko/20101126 Firefox/4.0b8pre
Build Identifier: Mozilla/5.0 (Windows NT 6.1; rv:2.0b8pre) Gecko/20101126 Firefox/4.0b8pre

This is perhaps not intended and must be fixed.

Reproducible: Always
Component: General → Add-ons Manager
OS: Windows 7 → All
Product: Firefox → Toolkit
QA Contact: general → add-ons.manager
Hardware: x86 → All
Version: unspecified → Trunk
Good catch. Thanks! Regressed between b6 and b7.
Status: UNCONFIRMED → NEW
blocking2.0: --- → ?
Ever confirmed: true
Keywords: regression
Whiteboard: [good first bug]
Known regression from bug 601022 - its caused by bug 611241. 

Guess we can keep this open so we don't lose track of it.
Depends on: 611241
Er, to clarify: the icons are there, and they're meant to be displayed in gray-scale. However, due to a bug in SVG filters, you can't see them.

And bug 611241 is already a blocker.
blocking2.0: ? → ---
Whiteboard: [good first bug]
This is still a blocker, if for some reason bug 611241 can't be fixed then we still need to fix this.
blocking2.0: --- → betaN+
Whiteboard: [needs 611241]
(In reply to comment #4)
> This is still a blocker, if for some reason bug 611241 can't be fixed then we
> still need to fix this.

What would the non-svg filter work-around look like?
(In reply to comment #5)
> What would the non-svg filter work-around look like?

The only other way I can think of keeping the grayscale effect would be to copy the image into a canvas element, and desaturate it there.

An a last fallback, we could just make the image slightly transparent. Doesn't look as good (or as noticable) as grayscale though.
Dao asserts this is a dup of bug 611241
Status: NEW → RESOLVED
Closed: 11 years ago
No longer depends on: 611241
Resolution: --- → DUPLICATE
Duplicate of bug: 611241
Duplicate of this bug: 621696
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.