Firefox Sync: Error while Syncing unknown error

RESOLVED DUPLICATE of bug 609380

Status

Cloud Services
Firefox Sync: Backend
--
major
RESOLVED DUPLICATE of bug 609380
7 years ago
7 years ago

People

(Reporter: Ray, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2.12) Gecko/20101026 Firefox/3.6.12 GTB7.1 (.NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; .NET4.0C; .NET CLR 1.1.4322)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2.12) Gecko/20101026 Firefox/3.6.12 GTB7.1 (.NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; .NET4.0C; .NET CLR 1.1.4322)

On 11/26/2010(PM) repeated attempts to Sync with Firefox Sync yielded an error with no detail. 

Reproducible: Always

Steps to Reproduce:
1. Click Sync symbol in bottom bar or click tool, then highlight Sync then click Sync Now.
2.
3.
Actual Results:  
Error while Syncing

Expected Results:  
Data Sync with my account on Firefox Sync server.

Under TOOLS, OPTIONS, SYNC TAB, show I am connected to my Firefox Sync Account.
(Reporter)

Updated

7 years ago
Version: unspecified → 3.6 Branch
Please post the log from about:sync-log

Comment 2

7 years ago
no comments.
Flags: in-testsuite+
Flags: in-litmus+

Comment 3

7 years ago
I am having the same problem. Error while syncing. Unknown error.

Comment 4

7 years ago
I am also having the same problem and it is consistently there no matter what I do.

Comment 5

7 years ago
Same here. On two identical XP computers, both with FF 3.6.13 and Sync 1.6.1, both successfully connected to Sync, on one it works OK, on another syncing always fails. Disabling all other add-ons did not help, un/reinstallation of Sync did not help. Will attach log file.

Comment 6

7 years ago
Created attachment 500720 [details]
Sync's log file with the error

attached log file with Sync error.

Comment 7

7 years ago
Update: I was able to resolve this problem by the following steps:

1. open Sync Preferences and uncheck all checkboxes but one (not the one that was giving the error according to the log)
2. perform update. It performed successfully. 
3. reopen Preferences and check another checkbox in addition to already checked

Repeat steps 2-3 until all checkboxes are checked again. In the end, I had them all checked like in the beginning, and now it updated successfully, no more error.

Comment 8

7 years ago
(In reply to comment #7)
> Update: I was able to resolve this problem by the following steps:
> 
> 1. open Sync Preferences and uncheck all checkboxes but one (not the one that
> was giving the error according to the log)
> 2. perform update. It performed successfully. 
> 3. reopen Preferences and check another checkbox in addition to already checked
> 
> Repeat steps 2-3 until all checkboxes are checked again. In the end, I had them
> all checked like in the beginning, and now it updated successfully, no more
> error.

This also worked for me! Thanks.

Comment 9

7 years ago
...but not for long. On the next day, it was back to the same error, and was again repaired by the same trick. The log file showed the trouble with passwords' update, so disabled Passwords, sync, re-enabled, sync, no more error - till the next time, probably. Also, I'm not 100% sure, but it seems that it in fact did not update the passwords, since after the successful sync I still did not find the new password I created yesterday on the work computer that has no problem and has already sync'ed.

Comment 10

7 years ago
I am experiencing much the same problem, except that of the two computers involved, one has an XP platform whereas the other x86 Windows Vista, otherwise my experience is the same as others, i.e.:

I have tried disabling all other add-ons to no avail.
I have also changed preferences and added them back consequently apparently resolving the problem until the next day when it returns as before.

Comment 11

7 years ago
FYI, I have the same issue on one XP computer with Firefox 4.0b8 (with preloaded Sync or 1.6.1).  Like the others I can resolve the problem for one day.  Unknown if its related but the computer experiencing this error is somewhat memory crippled and occasionally goes into a multi-second swapper lag.

My Windows 7/64 computer (also running 4.0b8 w/sync 1.6.1) has worked everytime.

Comment 12

7 years ago
I can confirm symptoms, as well as workaround an reoccurence as described in comment 9 on a Linux system running 4.0b8

"Mozilla/5.0 (X11; Linux i686; rv:2.0b8) Gecko/20100101 Firefox/4.0b8"

Comment 13

7 years ago
Not working on FF 3.6.13 and 4.0b8 on Windows Vista Home updated. For some reason this is working at work on Win XP Pro and FF 3.6.13. I have disabled add-ons and reset Sync more than once with the same account that works on the XP Pro machine.

Comment 14

7 years ago
Same issue... 2 machines with FF 4 Beta 9 running on Windows XP SP3.  One has no sync error, the other refuses to sync with an error log showing the passwords engine was the culprit.  The "fix" above, appears to work, but then throws a sync error on retry.
"
passwords failed: NS_ERROR_XPC_JS_THREW_STRING JS Stack trace: Res_get()@resource.js:376 < SyncEngine__processIncoming()@engines.js:511 < ()@engines.js:203 < SyncEngine__sync()@engines.js:768 < ()@engines.js:203 < WrappedNotify()@util.js:147 < Engine_sync()@engines.js:213 < WeaveSvc__syncEngine([object Object])@service.js:1738 < ()@service.js:1624 < WrappedNotify()@util.js:147 < WrappedLock()@util.js:119 < WrappedCatch()@util.js:97 < sync()@service.js:1529 < (1)@browser.js:5214
"
"Exception: Some engines did not sync correctly No traceback available"

Comment 15

7 years ago
In the last 48 hours I no longer see the problem.  Has anyone else had improvement?

This did NOT seem to coincide with the 4.0b9 update.

Comment 16

7 years ago
(In reply to comment #15)
> In the last 48 hours I no longer see the problem.  Has anyone else had
> improvement?
> 
> This did NOT seem to coincide with the 4.0b9 update.

After installing 1.6.2 update, this problem appears to have disappeared for me too....  Let's see if it has gone for good or comes back over the next few days.....

Comment 17

7 years ago
(In reply to comment #16)
> (In reply to comment #15)
> > In the last 48 hours I no longer see the problem.  Has anyone else had
> > improvement?
> > 
> > This did NOT seem to coincide with the 4.0b9 update.
> 
> After installing 1.6.2 update, this problem appears to have disappeared for me
> too....  Let's see if it has gone for good or comes back over the next few
> days.....

Sorry to say that the issue has returned......

Comment 18

7 years ago
Ditto. I notice no difference with the same parameters as before.

Comment 19

7 years ago
Firefox 4 Beta 10... still no sync.  Issue still occurs on XP SP3

about:sync-log snippet:

Service.Main         DEBUG	passwords failed: NS_ERROR_XPC_JS_THREW_STRING JS Stack trace: Res_get()@resource.js:376 < SyncEngine__processIncoming()@engines.js:511 < ()@engines.js:203 < SyncEngine__sync()@engines.js:768 < ()@engines.js:203 < WrappedNotify()@util.js:147 < Engine_sync()@engines.js:213 < WeaveSvc__syncEngine([object Object])@service.js:1738 < ()@service.js:1624 < WrappedNotify()@util.js:147 < WrappedLock()@util.js:119 < WrappedCatch()@util.js:97 < sync()@service.js:1529 < (5)@browser.js:5201

Comment 20

7 years ago
I've noticed that I now also get a sync failure on my XP machine, although that is rectified by manually syncing.  Following is the relevant section of the log from my Win7 (Vista type) machine:

2011-01-27 09:26:47	Store.Passwords      DEBUG	Adding login for sync.xmarks.com
2011-01-27 09:26:47	Engine.Passwords     DEBUG	Total (ms): sync 1975, processIncoming 1974, syncStartup 1, findDupe 2, getChangedIDs 0, createRecord 81, isEqual 82, reconcile 174, syncCleanup 0
2011-01-27 09:26:47	Service.Main         DEBUG	passwords failed: NS_ERROR_XPC_JS_THREW_STRING JS Stack trace: Channel_onStopRequest([object XPCWrappedNative_NoHelper],null,2153185310)@resource.js:444 < Res__request(...)@resource.js:357 < Res_get()@resource.js:376 < SyncEngine__processIncoming()@engines.js:511 < ()@engines.js:203 < SyncEngine__sync()@engines.js:768 < ()@engines.js:203 < WrappedNotify()@util.js:147 < Engine_sync()@engines.js:213 < WeaveSvc__syncEngine([object Object])@service.js:1739 < ()@service.js:1625 < WrappedNotify()@util.js:147 < WrappedLock()@util.js:119 < WrappedCatch()@util.js:97 < sync(false)@service.js:1530 < ([object Object])@service.js:554 < notify([object XPCWrappedNative_NoHelper])@util.js:1126
2011-01-27 09:26:47	Engine.Prefs         INFO	0 outgoing items pre-reconciliation

Thinking about changing back to Xmarks which functioned much better.  Only reason I changed was Xmarks was shutting down, but they seem to have been reprieved.

Comment 21

7 years ago
Is anyone looking at this?  The log with the relevant error was attached almost a month ago on 1/2/2011.

I'm seeing this on multiple machines:
Firefox 3.6.13 with Sync Addon 1.6.2 running on XP
Firefox 4.10b running on W7 x64

Comment 22

7 years ago
> Is anyone looking at this? 

from the top portion of this page:

Assigned To: Nobydy; OK to take it and work on it

Comment 23

7 years ago
> Thinking about changing back to Xmarks which functioned much better.  Only
reason I changed was Xmarks was shutting down

I did the same. Switched from xmarks when they started spamming with search suggestions or something similar. Now switched back. As soon as I store new password, or bookmark, in several seconds I see xmarks icon starts spinning. Firefox Sync doesn't, even with those items it has no problem with, like bookmarks.

Comment 24

7 years ago
I have found a solution (for me). Let's hope it works for the rest of you. It came, ironically, from the *X-Marks help page*. Soooo simple, I am wondering why I could not find this in the Firefox Help forums.

It is all about a corrupt file in your Firefox profile. Simply deleting the offending file(s) then restarting Firefox and re-syncing is what worked for me. It is apparent that Firefox Sync and X-Marks use the same file(s). Not that I don't like Chrome, I just prefer Firefox, and I was this close to abandoning ship.

BE SURE YOU HAVE A CLEAN BACK-UP, SOMEWHERE, OF THE BOOKMARK SET YOU DO NOT WANT TO LOSE.

   1. Close Firefox completely
   2. Open the Firefox profile folder
   3. Delete or rename all files named "places.sqlite", including "places.sqlite-journal" and any "places.sqlite.corrupt" files, if found.
   4. Restart Firefox.
   5. Immediately download your bookmarks from the Xmarks server by clicking Tools -> Xmarks -> Settings -> Advanced -> Download.

Comment 25

7 years ago
EDIT TO ABOVE REPLY: Step 5 indicates X-Marks. While this worlks for X-Marks, it also worked for FF Sync.

Comment 26

7 years ago
I'm going to hazard that the Comment 25 "solution" is yet another temporary fix.  It will comes back again.

In fact last week I uninstalled FFb9, blanked my entire profile directory (which of course includes places.sqlite*) and re-installed FFb10 from scratched.  And then synced up with my other computer.

That worked for about a day.

By the way typing those twelve letters on the other computer and having this computer to just start syncing was pretty cool.

Comment 27

7 years ago
I wonder if we all have something in common with our passwords?  I know one of mine has an @ symbol in it.  Maybe they're not escaping some character properly?

Comment 28

7 years ago
I think, developers are in much better position than we all to resolve the problem. Given the number of people in this thread, and the fact that only a small percentage of FF users know and care enough to find their way to this place, I think it's safe to say that Sync is not synchronizing passwords for anybody at all. If this is still below the threshold for the developers' attention, then I wonder what is above it.

Comment 29

7 years ago
This thread should be dead now, as my comment in #24 seems to be the charm, although it doesn't look like anyone has yet reported a failure, let alone if they have tried it. It should at least be published in the FF help forum as a possible solution instead of buried in Bugzilla.

Comment 30

7 years ago
I just tried the charm #24, and had zero effect. But even if it was really the cure, I think FF should be detecting and repairing it automatically: manual deletion of places.* by the user is hardly normal.

Comment 31

7 years ago
Sorry to hear it did not work :-( After four weeks of trying, it was like magic for me. The funny thing is, I went back to X-Marks as I am able to see and edit my bookmarks online, whereas I do not see that feature with Sync.

Comment 32

7 years ago
Actually, now I see that you were right: the first attempt of synchronization after having deleted places.*, has failed, but the next one succeeded! This does look like yet another bug, this "delayed" reporting: previously, after having reselected the preferences, it was saying that it succeeded once, when in fact it did not; now it's the other way around.

Comment 33

7 years ago
I tried the process at #24.  Didn't work for me.  Looks like Xmarks is probably going to be the path of least resistance for me, when I can find the time to reinstall it.

Comment 34

7 years ago
Created attachment 511085 [details]
New log, not the "failed to apply incoming record" in Store.Passwords

I've added a new sync-log patch since the error appears to be more verbose now.  I'm currently at the internal sync version that came with with 4.0b11.

Pretty sure this part is the failing section:

2011-02-09 13:00:30	Store.Passwords      WARN	Failed to apply incoming record {0b9f9ccd-6d24-40a1-a788-7d67e117ce52}
2011-02-09 13:00:30	Store.Passwords      WARN	Encountered exception: 'Can't add a login with both a httpRealm and formSubmitURL.' when calling method: [nsILoginManager::addLogin] Stack trace: PasswordStore__create()@resource://services-sync/engines/passwords.js:202 < Store_applyIncoming()@resource://services-sync/engines.js:217 < resource://services-sync/engines.js:203 < applyIncomingBatch()@resource://services-sync/engines.js:209 < doApplyBatch()@resource://services-sync/engines.js:676 < resource://services-sync/engines.js:742 < innerBind()@resource://services-sync/util.js:1467 < resource://services-sync/record.js:801 < Channel_onDataAvail()@resource://services-sync/resource.js:522
Component: General → Firefox Sync: Backend
Flags: in-testsuite+
Flags: in-litmus+
Product: Firefox → Mozilla Services
QA Contact: general → sync-backend
Version: 3.6 Branch → unspecified
Please, folks, when you all pile onto a bug with "me too", your issue is going to get confused with others.

The last comment, and the first log, both seem to be Bug 609380, so I'm duping this.

If you're seeing an issue that is *not* password sync failing because of an invalid record, please open a new issue in the Firefox Sync component.

Thanks!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 609380
(In reply to comment #34)
> Created attachment 511085 [details]
> New log, not the "failed to apply incoming record" in Store.Passwords
> 
> I've added a new sync-log patch since the error appears to be more verbose now.
>  I'm currently at the internal sync version that came with with 4.0b11.

Note that what you've observed is the *solution* to this problem -- we log and skip over invalid records, rather than failing hard. Sync should complete now, even when you have passwords which are no longer accepted by Firefox's login manager.

Comment 37

7 years ago
(In reply to comment #35)
> The last comment, and the first log, both seem to be Bug 609380, so I'm duping
> this.
>
> *** This bug has been marked as a duplicate of bug 609380 ***

Thanks Richard for the info and your work on the fix.

> Please, folks, when you all pile onto a bug with "me too", your issue is going
> to get confused with others.

I'm not sure exactly what to take from this.  The updaters were confirming different affected versions and possible work arounds.  No updates (until yours) were coming from developers nor anyone who could confirm that the problem was in the back-end, and no-one commenting here was qualified to identify the duplication, nor direct the discussion in more productive directions.

The posters here knew and cared enough to find the sync-log but it didn't occur to check the JS log that could have revealed the duplication.

If you can help us be more productive members of the bugzilla lay-community we're certainly interested.
(In reply to comment #37)

> I'm not sure exactly what to take from this.  The updaters were confirming
> different affected versions and possible work arounds.

I'm sure that's what everyone was trying to do, and I appreciate the effort, but "Error while Syncing" covers all manner of sins -- it's very likely that commenters were seeing several different issues, and one must look at the logs to tell.

This is a little bit like someone saying "my car won't start", and chiming in with "me too, we must have the same problem! I found jump-starting works", only to discover that the other guy has an empty gas tank. Well-intentioned, but not all that helpful.


> No updates (until
> yours) were coming from developers nor anyone who could confirm that the
> problem was in the back-end, and no-one commenting here was qualified to
> identify the duplication, nor direct the discussion in more productive
> directions.

Unfortunately, the bug didn't get assigned to the Firefox Sync component until yesterday; once it did I responded in about 30 minutes.

Sorry, bug triage can sometimes be frustratingly slow; getting the component right the first time can be a real help, but we know that's not always easy.


> The posters here knew and cared enough to find the sync-log 
> but it didn't occur to check the JS log that could have revealed the
> duplication.

My comment was addressed at comments 1, 3, 4, 5, mainly -- piling in with "me too" because of a front-end error message unfortunately isn't very helpful. It's true, though, that Bugzilla really isn't a good place to chat about workarounds.

Users are always welcome on irc.mozilla.org, #sync -- we'll do our best to help in real-time.


> If you can help us be more productive members of the bugzilla lay-community
> we're certainly interested.

The best advice I can give is to file a new bug unless:

* You can find a new bug which *precisely* describes your issue,
* That bug applies to exactly the same software version that you're using,
* That bug has been responded to by someone who's responsible for the module, and has undertaken some analysis, and that analysis matches your situation.

In this case, that means you should only chime in on an existing bug if you're seeing exactly the same Sync log messages, on exactly the same Sync add-on version... and even then it might not be the same problem.

All that means that the simplest course of action (at least for Sync) is to file a new bug, and always include your complete Sync log. We'll ask for more information if we need it, and we really don't mind at all if we have to dupe an issue. 

It's much easier to add a dupe than it is to try to clarify which comments are actually a completely different bug... and this way helps to make sure that your voice is heard, rather than being swallowed by an unrelated dupe.

We really appreciate your help!

Comment 39

7 years ago
Richard,

Thank you for setting out the protocol to be followed when contemplating a bug report.  I have read through both this Bug report and bug 609380.  Not being familiar with the complexities of the issue, I still find myself left wondering what my next best response is to assist and facilitate the resolution of this problem.

It would be helpful, therefore, if you could provide some guidance.  For example, should I simply provide a complete log file and leave it at that?  If so, is 'The log is disabled by default on Firefox 4. Go to about:config, find
services.sync.log.appender.debugLog.enabled and set it to true, then restart.' in any way relevant?  I note that I am using Firefox 3.6.13.  Or perhaps there is some other information that I should usefully submit.  Any guidance you can offer would be helpful.

Many thanks,

Comment 40

7 years ago
I confirmed that the solution to THIS problem is to download Sync 1.6.3b1 (or later) from https://services.mozilla.com/sync/updated/?channel=dev  Since updating, I've been running for days without an issue.

Hopefully with this explanation, it will be the last comment coming from this bug.

If the new version doesn't work, then you may have a different issue.  Open a new bug follow the steps that were listed (attaching about:sync-log).  Make sure you choose the product "Mozilla Services", Component "Firefox Sync: Backend".  This last part is important, but non-intuitive as it seems there really should be a Product Firefox / Component Sync alias.  Until I realized it was misfiled, our bug was stuck in no-mans land for months before a Sync developer looked at it.
(In reply to comment #40)

> Make
> sure you choose the product "Mozilla Services", Component "Firefox Sync:
> Backend".  This last part is important, but non-intuitive as it seems there
> really should be a Product Firefox / Component Sync alias.

Not everything lives under Firefox -- Sync actually works on mobile, Thunderbird, and SeaMonkey, too.

The "Backend" part doesn't mean it's a server, it means "the stuff behind the UI".

The other tip for this kind of thing is to search for a similar bug, and copy the component.

Taxonomies are flawed.
Many things are not in the product "firefox". The firefox product is basically only the Userinterface and everything else is in different products.
https://bugzilla.mozilla.org/describecomponents.cgi explains the products/components.
You can not know that as user and i have also sometimes problems to find the right components/products after 10 years doing volunteer work in bugzilla as bug triager.
That is not user friendly ? Sure but bugzilla is a tool for the developers and it's more or less developer friendly.

The product Firefox is usually the component that isn't watched by a developer.
I'm moving the bug reports usually to the right component if I got enough information from the reporter. The developers have already enough to read if they watch "their" component and they should fix bugs and don't read all the hundred new bug reports that are opened every day. Maybe 30% of this reports are only "useable" and others are invalid/worksforme/duplicate/incomplete. 
And this bug is a perfect example for that: the original reporter never answered.
I'm guilty that I didn't noticed that this bug got hijacked by "me too" people but this can happen with 100 bugzilla mails each day. I myself don't know much about sync and for example about:sync-log doesn't work in Seamonkey (hat I use) at the moment.
I feel guilty abusing this bug as an email thread, but here it goes...

(In reply to comment #42)
> The product Firefox is usually the component that isn't watched by a developer.
> I'm moving the bug reports usually to the right component if I got enough
> information from the reporter. The developers have already enough to read if
> they watch "their" component and they should fix bugs and don't read all the
> hundred new bug reports that are opened every day.

Thanks a lot for your continuous bug triaging efforts, btw. It has not gone unnoticed! :)

> I'm guilty that I didn't noticed that this bug got hijacked by "me too" people
> but this can happen with 100 bugzilla mails each day. I myself don't know much
> about sync and for example about:sync-log doesn't work in Seamonkey (hat I use)
> at the moment.

Weird. It should work... you may just have to turn on logging?

Comment 44

7 years ago
Created attachment 520520 [details]
about:sync-log for ff 4.0.12b, sync 1.7 on opensuse 11.4
(In reply to comment #44)
> Created attachment 520520 [details]
> about:sync-log for ff 4.0.12b, sync 1.7 on opensuse 11.4

Please file a new bug. This bug has long been resolved.
You need to log in before you can comment on or make changes to this bug.