Very long startup delay when "Looking for folders" and #news folder exists

RESOLVED WORKSFORME

Status

P3
normal
RESOLVED WORKSFORME
18 years ago
10 years ago

People

(Reporter: Michael.Kolmodin, Assigned: Bienvenu)

Tracking

({perf})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; SunOS 5.8 sun4u; en-US; m18) Gecko/20001109
BuildID:    Mozilla/5.0 (X11; U; SunOS 5.8 sun4u; en-US; m18) Gecko/20001109

When I open my mail account, I have to wait more than 3 minutes.
During this time Mozilla says: "Looking for folders". No network
activity, but heavy load on local disk and CPU. After this, it loads
the mailbox without any problems.

Reproducible: Always

Steps to Reproduce:
 -Start Mozilla
 -Select Tasks | Mail
 -Enter IMAP password in modal dialog.

Actual Results:    3 minutes delay before opening mailbox

Expected Results:  3 seconds delay before opening mailbox :-)

Ultra-Sparc 5, 320Mhz, 384K,one SCSI and one IDE disk. NS 4 also has a long
delay; however, NS has high CPU load and network traffic and no disk
load during the time which is roughly half of time for Mozilla.

Imap server welcome message (version hint):
* OK mafalda.lule.frontec.se IMAP4rev1 v12.261 server ready
(Reporter)

Comment 1

18 years ago
Trying to find out whether this is dependent on platform, bandwidth or total
size of mailboxes in my Mail directory I have tested on a portable PC at home,
the same PC at my work and a shared Sun workstation at my work. I have a 128
kbps ISDN connection between my work and home, hopefully more bandwidth
available internally at work;-)

The total size of my mailboxes is 350 Mb.

The portable is a Dell Latitude Cpi @350 Mhz, 64Mb, Win2K.

The workstation is a UltraSparc 10 with 2 CPU:s and 512 Mb RAM. However,
a lot of things are running there and Mozilla never gets more that 50%
of the CPU time.

Results:

Start-up time for the PC is the same as for the SUN at home, about three
minutes. This is true both at work and at home.

Start-up time for the Sun box at my work is 15 minutes (!).

Start-up time is the same if I temporarily clears the Mail directory.

Conclusions: This is neither platform nor bandwidth dependent. If it
is dependent on size of mailboxes, large mailboxes must be part of a
persistent state affecting Mozilla and/or the IMAP server between
invocations.

Feeling a bit silly - am I doing something wrong (causing you trouble)?
Or is it just just a slow IMAP server?

--Michael

--michael
Summary: Very long startup delay when "Looking for folders" → Very long startup delay when "Looking for folders"
(Reporter)

Comment 2

18 years ago
New checks... truss(1) reveals that during the long "looking for folders"
time, mozilla is stat'ing  the files in
 ~/.mozilla/default/ImapMail/myMailServer/#news. This is 1.5 Mb for
me, takes three minutes...

This is just unreasonable. dtmail starts up in less than 15 seconds, to list
the mailboxes takes another 10. Knews initiates the news reader over my
slow ISDN link in less than 70 seconds.

Tested with new build:
Mozilla/5.0 (X11; U; SunOS 5.8 sun4u; en-US; m18) Gecko/20001206,
no difference.


--m

Comment 3

18 years ago
Marking NEW this is a good bug report and someone needs to look at it.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 4

18 years ago
New scientific research. After trying in reinstall Mozilla in various
environments it seems that

- This problem exists if and only if the folder '#news' is present among
  the mail folders. This is obviously kind of virtual map, which does not
  exists physically in the mail servers folder directory.

- This folder is created when Mozilla is installed if and only if there is
  a .newsrc file in my home dir. My home dir is also the home for the imap
  server.

Obviously, it the create profile routine seems to be a a little to clever ;-)

--m

Comment 5

18 years ago
Reporter is this still occuring in the latest nightlies?

Comment 6

17 years ago
I can confirm this. Using Win2k nightly from May 1st.
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0.0+) Gecko/20020501

Using IMAP folders takes forever to load and I still haven't reached the point 
of being able to actually read my messages.

Comment 7

17 years ago
Verifying that removing ~/.newsrc solves the problem.

Comment 8

16 years ago
I just encountered this same problem for the first time after upgrading 1.1 ->
1.2. I have a wait of about 60  sec.
I'm on a Win95 platform.

Comment 9

16 years ago
Confirmed with Windows XP/ID:2003013104. Connecting takes forever when ~/.newsrc
is in my home (#news is showed). The mozilla will crash if I try to close mail
window when connection is on (=mozilla logo is animated).

Updated

14 years ago
Assignee: mscott → bienvenu
OS: Solaris → All
QA Contact: esther → grylchan
Hardware: Sun → All
Product: MailNews → Core

Updated

13 years ago
Blocks: 299198

Comment 10

12 years ago
does anyone still see this?

WFM per Johannes Koskine "I cannot see the problem anymore. Even though I have #news in my folders (somehow it appears automatically), it doesn't cost any launching time. Thunderbird starts quickly."  Thunderbird (currently 1.5.0.9) 

related to bug 67844?

(reporter and several others are gone)
Keywords: perf
Summary: Very long startup delay when "Looking for folders" → Very long startup delay when "Looking for folders" and #news folder exists

Comment 11

11 years ago
closing WFM based on comment 10
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.