Closed Bug 615086 Opened 9 years ago Closed 9 years ago

Minefield hangs on quit

Categories

(Firefox :: General, defect)

x86
macOS
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 614958
Firefox 4.0b8

People

(Reporter: notforyourmail, Assigned: ehsan)

References

Details

User-Agent:       Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b8pre) Gecko/20101127 Firefox/4.0b8pre
Build Identifier: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b8pre) Gecko/20101127 Firefox/4.0b8pre

For the past week or so, Minefield sometimes will hang when I try to quit the browser.  The browser must then be force quit.

Reproducible: Sometimes

Steps to Reproduce:
1.  Command-Q
2.  Minefield's windows close
3.  Minefield appears active in the dock.  OS X reports the application as hung.  Minefield must be force-quit.
Actual Results:  
Minefield hangs.

Expected Results:  
Minefield quits.
ive noticed the same thing with 4.0b8 on 32bit linux
i'll try to get a better backtrace next time it happens
Version: unspecified → Trunk
There is a known bug for FF on OSX. The browser goes into the offline mode and hangs if you quit it. Could it be that bug ?
sounds very likely now that i have this line from the backtrace
#10 0xb6cf6272 in nsSocketTransportService::Shutdown (this=0xb3e18000) at ../../../../netwerk/base/src/nsSocketTransportService2.cpp:465
#11 0xb6ce1fe8 in nsIOService::SetOffline (this=0xb581f000, offline=1) at ../../../../netwerk/base/src/nsIOService.cpp:729

except my end is running 32bit linux

another posibly related bug is that the menubar becomes non-responsive when i go into offline mode, and then i cant bring it back online
I don't think that the browser is going into offline mode.  At least, if it is, I can't tell, because the browser has already closed all its windows and no longer responds.  I'm certainly not putting it into offline mode myself...
nsXREDirProvider::DoShutdown (this=0xbfffe3f0) at toolkit/xre/nsXREDirProvider.cpp:798
this function sends out profile-change-net-teardown, which then triggers nsIOService::SetOffline which attempts to shutdown the IO thread
however the IO thread itself is hung on something else, nsSocketTransportService::DetachSocket (this=0xb3e18000, sock=0xb3e18290) at netwerk/base/src/nsSocketTransportService2.cpp:187
so it never detects that mShuttingDown == true, and never shuts down
I've reproduced the same backtrace on a local compile of Firefox, so now gdb isn't fighting me any more, I'll see if i can debug it more when i have time
This sounds like a dupe of bug 614286 to me...
Depends on: 614286
Should be fixed by bug 614286.  If you can reproduce this after that bug's landing, please reopen.
Assignee: nobody → ehsan
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Whiteboard: [fixed by bug 614286]
Target Milestone: --- → Firefox 4.0b8
Resolution: FIXED → DUPLICATE
Whiteboard: [fixed by bug 614286]
Duplicate of bug: 614958
i think i reproduced it under baa5ae44f0ba, but the debug symbols where missing again
(In reply to comment #10)
> i think i reproduced it under baa5ae44f0ba, but the debug symbols where missing
> again

This should be addressed by bug 614958.  Please file a new bug and CC me on it if you can reproduce this with a revision after the fixes for that bug.
I'm not sure if this is part of the same bug or not, but I've noticed that over the past few days, Minefield has thought that it was in offline mode after my Mac wakes from sleep.  However, I don't put it into offline mode, Offline Mode isn't checked, and my network is clearly up, because other programs are using it immediately upon wake.
(In reply to comment #12)
> I'm not sure if this is part of the same bug or not, but I've noticed that over
> the past few days, Minefield has thought that it was in offline mode after my
> Mac wakes from sleep.  However, I don't put it into offline mode, Offline Mode
> isn't checked, and my network is clearly up, because other programs are using
> it immediately upon wake.

Yes, that is part of that bug.
You need to log in before you can comment on or make changes to this bug.