Closed Bug 61511 Opened 20 years ago Closed 20 years ago

selecting some sans serif text adds extra space before and after word(s)

Categories

(Core :: DOM: Selection, defect, P3)

x86
Windows 98
defect

Tracking

()

VERIFIED DUPLICATE of bug 52596

People

(Reporter: jameslariviere, Assigned: mjudge)

References

()

Details

(Keywords: top100)

Attachments

(1 file)

DESCRIPTION:

Let's see if I can explain this right...
If you select text that is font weight (bold) and font family (sans serif: like
MS Sans Serif, Impact, Lucida Sans, but not every sans serif font) extra spaces
are added to the beginning and end of the selected words.  This causes layout
errors.


STEPS TO REPRODUCE:

view test case.


ACTUAL RESULTS:

Double click the word "some" in each paragraph.  In the (MS Sans Serif, Impact,
Lucida Sans) paragraphs, the selected word "some" now has extra space at its
beginning and end.

Look at the ending of the sentence.  It is now clipped out because of the extra
space added around the word "some".


EXPECTED RESULTS:

The selection of the word "some" should behave the same way as to the other font
families.


DOES NOT WORK CORRECTLY ON:

Win98 build 11-28-04
adding url and keyword.

Another site that this messes up on is http://www.mutualfundsnet.com
Attached file testcase

*** This bug has been marked as a duplicate of 52596 ***
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
Yep Agree. damn this is wierd.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.