A folder disappears from the folder pane after renaming

VERIFIED FIXED

Status

SeaMonkey
MailNews: Message Display
P3
normal
VERIFIED FIXED
18 years ago
14 years ago

People

(Reporter: Ninoschka Baca, Assigned: Navin Gupta)

Tracking

Trunk
x86
Windows 95

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

18 years ago
Build 2000-11-28-09: Win95

Overview: In certain cases after renaming a folder it appears to have 
disappeared. The folder and all its subfolders actually became Unsubscribed. 
Renaming a folder should never result in unsubscribing the folder.

Steps to reproduce: (I haven't reproduced this on another account but can easily 
reproduce using my account) 
1. I open my nbaca account which uses IMAP on nsmail-2
2. I select a folder called 'Seamonkey' which includes 24 subfolders, each 
folder having many messages (about 750 total messages)
3. Right click onto the mouse, select Rename folder and rename the folder (i.e. 
Seamonkey --> Seamonkey1). No change occurs.
4. Exit and restart

Actual Results: The 'Seamonkey1' folder is not there and the 'Seamonkey' folder 
also does not appear. Select File|Subscribe and the new folder 'Seamonkey1' is 
there but it's not subscribed. In fact none of its subfolders are subscribed. 
After subscribing to 'Seamonkey1' and all its subfolders then they appear in the 
folder pane.

Expected Results: After exiting and restarting the folder should appear along 
with all its subfolders in the folder pane. I should not require subscribing.

Additional Information:
- After step 3, if renaming the folder displays the change immediately then I 
can reproduce the problem reported in bug# 60914 where a warning appears when a 
subfolder is selected.
(Reporter)

Comment 1

18 years ago
Created attachment 19896 [details]
1st session, renaming folder
(Reporter)

Comment 2

18 years ago
This first attachment is an IMAP log created in the first session when renaming 
the folder occured.
(Reporter)

Comment 3

18 years ago
Created attachment 19897 [details]
2nd session, after restarting
(Reporter)

Comment 4

18 years ago
This second attachment is an IMAP log after restarting the application. I 
couldn't see the 'Seamonkey1' or 'Seamonkey' folder in the folder pane. The 
Subscribe dialog showed the new folder name but it was unsubscribed.
(Reporter)

Comment 5

18 years ago
Adding Seth to the Cc: list since he saw this on my system.
QA Contact: esther → huang
(Reporter)

Comment 6

18 years ago
After not seeing the folder in Netscape6 I also checked the account using 4.7. 
4.7 shows the same results where the folder does not appear and the Subscribe 
dialog displays it but it is unsubscribed.
(Reporter)

Comment 7

18 years ago
I reproduced the problem using a test account on nsmail-1.
The folder is called 'folder02' and includes 1358 messages.
After renaming the folder to 'folder02a' the change did not display.
After exiting and restarting neither folder appears yet the Subscribe
dialog has the new folder. After subscribing to 'folder02a' then it
and its messages appear.

Comment 8

18 years ago
The renamed folder seems having refresh problem, I did try on my personal 
account. After renamed the fodler, it won't reflect the change right away, but 
after you expand the renamed folder will display again, I did see bug 60914 
which I reported few days ago, but so far I couldn't reproduce this specific 
problem, I am wondering to know whether this is because of Ninoschka's 
renamed folder with 24 subfolders or not??

Comment 9

18 years ago
From Ninoschka 1st session log file:
-----------------------------------------------------------------------------
-382461[100c25f0]: nsmail-2:A:SendData: 8 rename "SeaMonkey1a2" "SeaMonkey1a2b"
0[7b1ec0]: nsmail-2:A:SendData:TellThreadToDie: 9 logout
-382461[100c25f0]: nsmail-2:A:CreateNewLineFromSocket: (null)
-------------------------------------------------------------
It seems that you logout before the renamed folder reflect the chang, can you 
try keep the same session longer time and try expand the rename folder again to 
see it will reflect change or not? I did get the following log which rename 
fodler successfully but just need to wait a little bit while and expand the 
folder again....
----------------------------------------------------------------------------
185[78c9ec0]: nsmail-2:S-Milestones:CreateNewLineFromSocket: 6 OK Completed
185[78c9ec0]: nsmail-2:S-Milestones:SendData: 7 rename "Milestones" 
"Milestones_test"
185[78c9ec0]: nsmail-2:S-Milestones:CreateNewLineFromSocket: * 1 EXPUNGE
185[78c9ec0]: nsmail-2:S-Milestones:CreateNewLineFromSocket: * 0 EXISTS
185[78c9ec0]: nsmail-2:S-Milestones:CreateNewLineFromSocket: * 0 RECENT
185[78c9ec0]: nsmail-2:S-Milestones:CreateNewLineFromSocket: 7 OK Completed
185[78c9ec0]: nsmail-2:S-Milestones:SendData: 8 subscribe "Milestones_test"
185[78c9ec0]: nsmail-2:S-Milestones:CreateNewLineFromSocket: 8 OK Completed
185[78c9ec0]: nsmail-2:S-Milestones:SendData: 9 unsubscribe "Milestones"
185[78c9ec0]: nsmail-2:S-Milestones:CreateNewLineFromSocket: 9 OK Completed
----------------------------------------------------------------------------
I am thinking this bug will be a performance issue since it should reflect the 
change right away.....

Comment 10

18 years ago
reassigning to naving
Assignee: putterman → naving

Comment 11

18 years ago
>it should reflect the change right away
Mail performance related bug, adding mail1 on the keywords.
Keywords: mail1
(Assignee)

Comment 12

18 years ago
fix checked in. Performance issue may have to be dealt with separately.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 13

18 years ago
WinNT 01-02-11-Mtrunk build
Those folders (before and after rename) seem both display on the folder pane and
subscribe dialog now...but after renamed folder, need to select the folder again
in order to see the change (that is another bug 64143 which I logged
already)....
Before I mark as verified, I prefer Ninoschka verify again on her mail account
since original problem did occur on some specific mail account and it did take a
while to rename the folder.....
Ninoschka, can you double check for me? Please mark as verified if you agree
this fix. Reopen this bug if problem still occurs on your account. Thanks.

(Reporter)

Comment 14

18 years ago
It's working much better now.
Marking Verified.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.