Closed Bug 615142 Opened 9 years ago Closed 9 years ago

Opening a tab to new window unnecessarily reloads entire webpage

Categories

(Firefox Build System :: General, enhancement)

x86_64
Windows 7
enhancement
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 449734

People

(Reporter: james, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-GB; rv:1.9.2.12) Gecko/20101026 Firefox/3.6.12
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-GB; rv:1.9.2.12) Gecko/20101026 Firefox/3.6.12

When right clicking a tab and clicking 'Open in new window', the new window requests a refresh of the page from the webserver.

Objects embedded inside the page such as Flash and Java applets are forced to reload. This causes problems on websites where media is streamed (e.g. video) as users may need to re-authenticate and/or wait for streams to reload, particularly if the site doesn't make good use of cookies etc.

The problem is worst on video p2p sites, as the page refresh can force a user to essentially start a whole new session with the server. Establishing brand new connections to other peers can take some time before streams are resumed. As the 'Open in new window' option takes a tab and puts it into a new window (purely client-side) I see the page request for the new window as unnecessary. 

It would be better if the 'Open in new window' had some kind of in-line loading from the existing tab (i.e. seemless).

Reproducible: Always

Steps to Reproduce:
1. Go on any Veetle.com video
2. Once video has loaded, right click the current tab and click 'Open in new Window'
Actual Results:  
Current tab is closed and new window loaded with new page request. Video is stopped whilst stream takes time to reload.

Expected Results:  
See detail.
This should be fixed for Firefox 4.
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 449734
Component: Build Config → General
Product: Firefox → Firefox Build System
You need to log in before you can comment on or make changes to this bug.