Don't fire focus event for current focused accessible when document gets focus

RESOLVED FIXED in mozilla2.0b8

Status

()

Core
Disability Access APIs
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: surkov, Assigned: surkov)

Tracking

(Blocks: 1 bug, {access})

unspecified
mozilla2.0b8
access
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

7 years ago
Created attachment 493685 [details] [diff] [review]
patch

It was related with focus handling in dialogs where we get focus event for document and then for focused element. Nowdays this code makes us to fire a11y focus event for focused element twice. That's not necessary any more since we coalesce focus events from the same document and in other words we fire a11y focus event for focused element. I don't like current approach since it's timing related and may result in twiced a11y focus events what's not necessary.
Attachment #493685 - Flags: review?(bolterbugz)
Attachment #493685 - Flags: approval2.0?
I'd like our guru to take a try build for a spin here.
(Assignee)

Comment 2

7 years ago
(In reply to comment #1)
> I'd like our guru to take a try build for a spin here.

This one contains all my latest patches:
http://ftp.mozilla.org/pub/mozilla.org/firefox/tryserver-builds/surkov.alexander@gmail.com-02c4399322f7

Comment 3

7 years ago
I just ran with this build, and cannot report anything wrong with it. It reports focus fine when switching from one app to another or when switching tabs. I also tested with both NVDA and JAWS to make sure.
Comment on attachment 493685 [details] [diff] [review]
patch

r+a=me conditional on Marco's second spin working out ok.
Attachment #493685 - Flags: review?(bolterbugz)
Attachment #493685 - Flags: review+
Attachment #493685 - Flags: approval2.0?
Attachment #493685 - Flags: approval2.0+

Comment 5

7 years ago
Nope, there's something wrong when you go to www.youtube.com and JAWS running. The browser freezes either immediately, or after you enter a search term and press ENTER. It doesn't appear to hang taskmanager-wise, but JAWS doesn't read anything any more, no keyboard commands work etc.
(Assignee)

Comment 6

7 years ago
try server build against trunk - http://ftp.mozilla.org/pub/mozilla.org/firefox/tryserver-builds/surkov.alexander@gmail.com-25bba87ca3ce
(Assignee)

Comment 7

7 years ago
new try server build - http://ftp.mozilla.org/pub/mozilla.org/firefox/tryserver-builds/surkov.alexander@gmail.com-6f2e407b7f90

Comment 8

7 years ago
This latest try-server build works fine with JAWS and Youtube as well. I cannot reproduce the problems I describe in comment #5 with this build. So whatever finetuning you did seems to have solved this problem.
(Assignee)

Comment 9

7 years ago
landed on 2.0 - http://hg.mozilla.org/mozilla-central/rev/dfedd535f514
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla2.0b8
You need to log in before you can comment on or make changes to this bug.