Closed Bug 615349 Opened 11 years ago Closed 4 years ago

Print preview hides all tabs, close button closes Firefox

Categories

(Core :: Print Preview, defect)

1.9.2 Branch
x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 133787

People

(Reporter: quidam, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.2.12) Gecko/20101026 Firefox/3.6.12
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.2.12) Gecko/20101026 Firefox/3.6.12

Entering the print preview of a page makes all tabs inaccessible and invisible. When I click on the [x] button in the upper right corner to close the print preview, the entire browser window is closed.

Hitting the [x] button on a print preview window should do the same as the [Close] button: close the print preview, not close Firefox.

Alternatively, print preview could open in a separate tab, or replace the tab that is being printed. After all it is just another view of that tab. If there are reasons for the print preview to be modal, it should be more obvious that my tabs are still there and how to get back to them.

Reproducible: Always

Steps to Reproduce:
1. Open a web page
2. File | Print preview
3. I don't want to print after all. Instinctively click on [x]
Actual Results:  
Firefox closes

Expected Results:  
Print preview closes, back to HTML view
Related: bug 133787

From the summary of that bug:
> In Mozilla's print preview, however, Alt-F4 appears to do nothing. Another example is clicking the upper right-hand "X." This usually has the same
effect in Windows as Alt-F4. In Mozilla's print preview, however, it restores
browser mode, and keeps the window open.

Now Alt-F4 still does nothing, but clicking on "X" closes the browser window. 

> The current implementation does not close the Window when the user clicks on the
upper right-hand "X" because the user may have typed data into a form, and that
would be lost if the browser window were closed. 

Exactly. Why was this changed?
Version: unspecified → 3.6 Branch
Reporter, this looks like bug 564147? and would be fixed by bug 133787?
Component: General → Print Preview
Product: Firefox → Core
QA Contact: general → printing
Version: 3.6 Branch → 1.9.2 Branch
Status: UNCONFIRMED → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 133787
You need to log in before you can comment on or make changes to this bug.