Closed Bug 615443 Opened 9 years ago Closed 9 years ago

Ordering of contributors localised in preferences can be incorrect

Categories

(Toolkit :: Add-ons Manager, defect)

x86
macOS
defect
Not set

Tracking

()

VERIFIED FIXED
mozilla2.0b8
Tracking Status
blocking2.0 --- final+

People

(Reporter: ehsan, Assigned: mossop)

References

Details

(Keywords: regression)

Attachments

(1 file, 1 obsolete file)

It turns out that the last part of the test for bug 553094 fails on Mac debug builds, for example:

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1291083603.1291084745.6871.gz
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1291083790.1291085283.9345.gz

I disabled that part, and I'm filing this bug so that Mossop can investigate why, address the failure, and re-enable that part of the test.

http://hg.mozilla.org/mozilla-central/rev/e57dc7264ff5
Why did it suddenly start failing?
Assignee: nobody → dtownsend
(In reply to comment #1)
> Why did it suddenly start failing?

No idea.  The failure might have happened earlier but was masked by the xpcshell broken-ness.
The test fails because the contributors are returned out of order because for some reason nsIPrefBranch.getChildList isn't returning the preferences in order. I'm not sure if that was ever meant to be guaranteed or not though.
Dan, is nsIPrefBranch.getChildList meant to be guaranteeing anything about the ordering of the results or do we have to sort the list ourselves? Also any idea why this might have changed recently?
Attached patch patch rev 1 (obsolete) — Splinter Review
We shouldn't have been assuming the ordering of this, sorting it makes sure it is what we want.
Attachment #494554 - Flags: review?(robert.bugzilla)
Summary: Investigate why the last part of the test for bug 553094 fails on Mac debug builds → Ordering of contributors localised in preferences can be incorrect
Attached patch patch rev 1Splinter Review
Forgot to re-enable the test
Attachment #494554 - Attachment is obsolete: true
Attachment #494555 - Flags: review?(robert.bugzilla)
Attachment #494554 - Flags: review?(robert.bugzilla)
Whiteboard: [has patch][needs review rs]
Whiteboard: [has patch][needs review rs] → [has patch]
This is a regression from 3.6 and so should be fixed.
blocking2.0: --- → final+
Keywords: regression
Landed: http://hg.mozilla.org/mozilla-central/rev/7ff5dc0e487b
Status: NEW → RESOLVED
Closed: 9 years ago
Flags: in-testsuite+
Flags: in-litmus-
Resolution: --- → FIXED
Target Milestone: --- → mozilla2.0b8
Whiteboard: [has patch]
Verified fixed based on check-in and not failing tests.
Status: RESOLVED → VERIFIED
(In reply to comment #4)
> Dan, is nsIPrefBranch.getChildList meant to be guaranteeing anything about the
> ordering of the results or do we have to sort the list ourselves? Also any idea
> why this might have changed recently?

We did change that code recently, but I can't see why it would've affected order. Regardless, you're right, it doesn't make guarantees.
You need to log in before you can comment on or make changes to this bug.