Closed Bug 615492 Opened 10 years ago Closed 10 years ago

crash [@ js::PropertyTable::search(int, bool) ]

Categories

(Core :: JavaScript Engine, defect)

x86
Windows 7
defect
Not set
critical

Tracking

()

VERIFIED DUPLICATE of bug 595975
Tracking Status
blocking2.0 --- betaN+

People

(Reporter: scoobidiver, Assigned: gal)

Details

(Keywords: crash, qawanted, regression, Whiteboard: [sg:dupe 595975])

Crash Data

It is a new crash signature that exists in 4.0b7 and 4.0b8pre builds.
It is #60 top crasher in 4.0b8pre for the last 3 days.

Signature	js::PropertyTable::search(int, bool)
UUID	c2679767-8606-4d35-ab4c-89ec92101129
Time 	2010-11-29 11:42:18.706114
Uptime	6010
Last Crash	6649 seconds (1.8 hours) before submission
Install Age	6010 seconds (1.7 hours) since version was first installed.
Product	Firefox
Version	4.0b8pre
Build ID	20101129030317
Branch	2.0
OS	Windows NT
OS Version	6.1.7601 Service Pack 1, v.178
CPU	x86
CPU Info	GenuineIntel family 6 model 15 stepping 13
Crash Reason	EXCEPTION_ACCESS_VIOLATION_READ
Crash Address	0x3b240
App Notes 	AdapterVendorID: 8086, AdapterDeviceID: 2a02
MSAFD Tcpip [TCP/IP] : 2 : 1 :
MSAFD Tcpip [UDP/IP] : 2 : 2 : %SystemRoot%\system32\mswsock.dll
MSAFD Tcpip [RAW/IP] : 2 : 3 :
MSAFD Tcpip [TCP/IPv6] : 2 : 1 : %SystemRoot%\system32\mswsock.dll
MSAFD Tcpip [UDP/IPv6] : 2 : 2 :
MSAFD Tcpip [RAW/IPv6] : 2 : 3 : %SystemRoot%\system32\mswsock.dll
Proveedor de servicios RSVP TCPv6 : 2 : 1 :
Proveedor de servicios RSVP TCP : 2 : 1 : %SystemRoot%\system32\mswsock.dll
Proveedor de servicios RSVP UDPv6 : 2 : 2 :
Proveedor de servicios RSVP UDP : 2 : 2 : %SystemRoot%\system32\mswsock.dll
MSAFD NetBIOS [\Device\NetBT_Tcpip_{A22183F0-DD7D-4A83-92FB-B655969E5ED0}] SEQPACKET 8 : 2 : 5 :
MSAFD NetBIOS [\Device\NetBT_Tcpip_{A22183F0-DD7D-4A83-92FB-B655969E5ED0}] DATAGRAM 8 : 2 : 2 : %SystemRoot%\system32\mswsock.dll
MSAFD NetBIOS [\Device\NetBT_Tcpip_{C1BD90B2-B82E-46CC-B991-E1CB2B4A2882}] SEQPACKET 3 : 2 : 5 :
MSAFD NetBIOS [\Device\NetBT_Tcpip_{C1BD90B2-B82E-46CC-B991-E1CB

Frame 	Module 	Signature [Expand] 	Source
0 	mozjs.dll 	js::PropertyTable::search 	js/src/jsscope.cpp:319
1 	mozjs.dll 	JSObject::nativeLookup 	js/src/jsscope.h:660
2 	mozjs.dll 	js_GetPropertyHelper 	js/src/jsobj.cpp:5099
3 	mozjs.dll 	js_GetMethod 	js/src/jsobj.cpp:5135
4 	mozjs.dll 	GetCustomIterator 	js/src/jsiter.cpp:403
5 	mozjs.dll 	js::GetIterator 	js/src/jsiter.cpp:705
6 	mozjs.dll 	js_ValueToIterator 	js/src/jsiter.cpp:836
7 	mozjs.dll 	js::mjit::stubs::Iter 	js/src/methodjit/StubCalls.cpp:2144
8 	mozjs.dll 	js::mjit::EnterMethodJIT 	js/src/methodjit/MethodJIT.cpp:745
9 	mozjs.dll 	CheckStackAndEnterMethodJIT 	js/src/methodjit/MethodJIT.cpp:770
10 	mozjs.dll 	js::mjit::JaegerShot 	js/src/methodjit/MethodJIT.cpp:787
11 	mozjs.dll 	js::RunScript 	js/src/jsinterp.cpp:654
12 	mozjs.dll 	js::Invoke 	js/src/jsinterp.cpp:737
13 	mozjs.dll 	js::ExternalInvoke 	js/src/jsinterp.cpp:858
14 	mozjs.dll 	JS_CallFunctionValue 	js/src/jsapi.cpp:4973
15 	xul.dll 	nsXPCWrappedJSClass::CallMethod 	js/src/xpconnect/src/xpcwrappedjsclass.cpp:1694
16 	xul.dll 	nsXPCWrappedJS::CallMethod 	js/src/xpconnect/src/xpcwrappedjs.cpp:588
17 	xul.dll 	PrepareAndDispatch 	xpcom/reflect/xptcall/src/md/win32/xptcstubs.cpp:114
18 	xul.dll 	SharedStub 	xpcom/reflect/xptcall/src/md/win32/xptcstubs.cpp:141
19 	xul.dll 	nsEventListenerManager::HandleEventSubType 	content/events/src/nsEventListenerManager.cpp:1114

More reports at:
http://crash-stats.mozilla.com/report/list?product=Firefox&platform=windows&query_search=signature&query_type=exact&query=&range_value=4&range_unit=days&hang_type=any&process_type=any&plugin_field=&plugin_query_type=&plugin_query=&do_query=1&admin=&signature=js%3A%3APropertyTable%3A%3Asearch%28int%2C%20bool%29
It is #19 top crasher on 4.0b8pre for the last 3 days.
blocking2.0: --- → ?
blocking2.0: ? → betaN+
Assignee: general → gal
blocking2.0: betaN+ → ?
Any hints on what code triggers this? urls?
Keywords: qawanted
blocking2.0: ? → betaN+
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 595975
Status: RESOLVED → VERIFIED
Group: core-security
hiding until we are sure this is unrelated to bug 626631 or have a fix there.
Crash Signature: [@ js::PropertyTable::search(int, bool) ]
Whiteboard: [sg:dupe 595975]
Doesn't seem to be anything sensitive in this bug
Group: core-security
You need to log in before you can comment on or make changes to this bug.