Last Comment Bug 615530 - Update .bt entry in PSL
: Update .bt entry in PSL
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Networking: Domain Lists (show other bugs)
: unspecified
: All All
: -- normal with 1 vote (vote)
: ---
Assigned To: Gervase Markham [:gerv]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-11-30 06:17 PST by Gervase Markham [:gerv]
Modified: 2011-03-16 09:48 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
.17-fixed
.19-fixed


Attachments
Patch from .bt registry (361 bytes, patch)
2010-11-30 06:18 PST, Gervase Markham [:gerv]
jst: approval2.0+
dveditz: approval1.9.2.17+
dveditz: approval1.9.1.19+
Details | Diff | Splinter Review

Description Gervase Markham [:gerv] 2010-11-30 06:17:28 PST

    
Comment 1 Gervase Markham [:gerv] 2010-11-30 06:18:23 PST
<sigh> Oops. Here's the initial comment:

Dear Sir/Madam,

Greetings from Bhutan.

I am a system administrator working in DrukNet, under Bhutan Telecom. We
are an ISP (owned by the government of Bhutan) and we are also
responsible for .bt ccTLD.

It recently came to my notice that the suffix list for .bt ccTLD has
never been updated. In fact, not submitted by DrukNet at all. Therefore,
I have attached a unified diff of the changes that needs to be made to
the .bt siffix list.
We have had people complaining about cookie problem with some of the web
browsers while browsing some of the .bt domains.

Thank you for your time and effort.

Best regards
-- 
Lungten Wangchuk 
DrukNet (ISP Division) 
Bhutan Telecom 
2/28 Drophen Lam
Thimphu
Comment 2 Gervase Markham [:gerv] 2010-11-30 06:18:59 PST
Created attachment 493961 [details] [diff] [review]
Patch from .bt registry
Comment 3 Patrick 2010-12-05 15:41:02 PST
Sorry to ask such questions here - I guess it must be obvious somehow. But still then, I just wonder: What is the use of this bug? Aren't all the facts clear and simple? You apply the patch - done. What am I missing? Can you provide a link to some kind of policy document that requires the bug to be created? How long will it "exists" here until it gets fixed? Wouldn't it have been easier to to apply the patch then to open a bug? :-)
Comment 4 Gervase Markham [:gerv] 2010-12-09 12:41:58 PST
We have bugs to track all changes. I just need to get around to checking it in (which is non-trivial, because the tree is often closed these days).

Gerv
Comment 5 Gervase Markham [:gerv] 2010-12-09 12:44:21 PST
Comment on attachment 493961 [details] [diff] [review]
Patch from .bt registry

Requesting approval.

Gerv
Comment 6 Patrick 2010-12-09 13:05:17 PST
Sorry again ... :-) by now I realize that the file .dat file seems to actually be part of the mozilla/firefox source tree and I can in that case understand...

I was imagining that the file would somehow be in a repository of its own under publicsuffix.org and that it would then be automatically "imported" for each mozilla/firefox build by the build scripts (with the public key of publicsuffix.org beeing part of the mozilla source tree and the file signature beeing checked automatically or something like that...)

Too much fantastic thinking on my side...! :-) Be it the way it is.
Comment 7 Patrick 2011-01-17 01:40:10 PST
Would be nice if this could make it into firefox 4 ... any chance ?
Comment 8 Gervase Markham [:gerv] 2011-01-27 07:10:07 PST
Trunk: http://hg.mozilla.org/mozilla-central/rev/09bfc85b151c

Gerv
Comment 9 Daniel Veditz [:dveditz] 2011-01-28 10:13:33 PST
Comment on attachment 493961 [details] [diff] [review]
Patch from .bt registry

approved for 1.9.2.15 and 1.9.1.18, a=dveditz for release-drivers

Note You need to log in before you can comment on or make changes to this bug.