Scrolling a page while certain flash videos are in view is laggy

RESOLVED DUPLICATE of bug 591687

Status

()

Core
Plug-ins
RESOLVED DUPLICATE of bug 591687
8 years ago
8 years ago

People

(Reporter: jdm, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

I can reproduce this consistently on my MBP, and not on my Linux machine.

STR:
1. visit http://vindictus.nexon.net/intro/?PARTNERKEY=MK017SVG0281321&gclid=CK-X2M2iyaUCFQTNKgodiUl3Zw
2. scroll the page as the movie plays, notice the lag
3. when the movie finishes, scroll the page again. notice how smoothly it scrolls.

ALT STR:
1. visit questionablecontent.net
2. refresh the page until the flash ad in the bottom right shows a large white angry bear
3. wait until the bear splits apart and a big shiny ad for Vindictus appears
4. scroll up and down the page. note how scrolling is smooth as long as the flash ad is not visible
Requesting blocking, as this is a pretty bad user experience when pages start to crawl.
blocking2.0: --- → ?
This is probably related to bug 591687.
Josh, I'm marking this blocking but mostly for you to evaluate, or dupe if you agree with Scotts comment above.
Assignee: nobody → joshmoz
blocking2.0: ? → betaN+

Comment 4

8 years ago
Scrolling is pretty fast for me in the given test cases, not laggy at all, but I have a fast machine I wouldn't be surprised if that stuff is noticeably slower for others. I think Scott is probably right and I'm going to dupe this against bug 591687.

Just to have some more documentation of the problem though, reporter - can you post more specific system specs (processor, RAM, video card, OS version), your Flash version, and the version of Minefield you're using? Are you using a regular 64-bit nightly build?
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 591687

Updated

8 years ago
Assignee: joshmoz → nobody

Updated

8 years ago
blocking2.0: betaN+ → ---
OS X 10.6.4, MBP with 2.66GHz Intel Core 2 Duo, 8GB RAM.  Flash version is 10.1.85.3, Minefield is the latest mac nightly.  Apparently I've got a NVIDIA GeForce 9600M GT.

Comment 6

8 years ago
Do things work any better if you update to Flash 10.1.102.64? Updating to Mac OS X 10.6.5 should do that for you, kill two birds with one stone.
Josh, I updated to 10.6.5 and now have Flash 10.1.102.64, but http://vindictus.nexon.net/intro/?PARTNERKEY=MK017SVG0281321&gclid=CK-X2M2iyaUCFQTNKgodiUl3Zw is still incredibly laggy for me.  I haven't noticed any performance improvements when scrolling while certain flash movies are visible.
FWIW, with layers.accelerate-none turned on, I get uninterrupted and fairly smooth (but slow) scrolling, compared to the exceedingly jumpy scrolling with accelerated layers.
You need to log in before you can comment on or make changes to this bug.