Greasemonkey and PDF OS X plugin halts Firefox execution since 3.6.12

RESOLVED WORKSFORME

Status

()

Firefox
Extension Compatibility
--
major
RESOLVED WORKSFORME
7 years ago
5 years ago

People

(Reporter: Marek Wawrzyczny, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-GB; rv:1.9.2.12) Gecko/20101026 Firefox/3.6.12
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-GB; rv:1.9.2.12) Gecko/20101026 Firefox/3.6.12

This morning Firefox failed to start. I suspect that Firefox updated automatically to 3.6.12 last night, before shutdown.

Starting from CLI made no difference and there were no error messages.
Starting from CLI in '-safe-mode' worked and allowed disabling of all addons/plugins.
Starting from CLI in '-migration' mode resulted in a crash - report sent through crash manager.

Once plugins/addons were disabled, Firefox started normally. I then re-enabled addons until I was able to find those responsible for the failed startup.

The two plugins which cause Firefox to fail to start are:

1. Greasemonkey 0.8.20100408.6
2. Firefox PDF Plugin for Mac OS X 1.1.3

It appears that the 3.6.12 changes have caused these plugins to fail.

Reproducible: Always

Steps to Reproduce:
1. Enable/install Greasemonkey and/or PDF Plugin
2. Restart Firefox (3.6.12)
3. Firefox will quit without any notifications
Actual Results:  
Firefox icon bounces on Dock, application exits.

If started from CLI, application just quits without any stdout/stderr messages.

Expected Results:  
Start and work??? :)
(Reporter)

Comment 1

7 years ago
I do understand that this is in a way a problem with the plugins but having looked at the 3.6.12 fix, it doesn't appear as if it should effect plugins.

Additionally, there's a problem that Firefox doesn't detect the failure and disable the offending plugins.

I will contact the plugin devs separately.

Comment 2

7 years ago
FWIW, as recorded on the bug this user reported for Greasemonkey, I am unable to reproduce: https://github.com/greasemonkey/greasemonkey/issues/issue/1234
(Reporter)

Comment 3

7 years ago
I have since done the following:

1. Started Firefox with a new, clean user profile (TestUser).
2. Installed both Greasemonkey and PDF for Mac OS X

Firefox worked with the two plugins enabled.

Following that, I tried the following:

1. Started Firefox in the original, default user profile in safe-mode with all plugins disabled.
2. Re-enabled Greasemonkey plugin and restarted Firefox - Firefox started with no problems
3. Re-enabled PDF for Mac OS X and restarted Firefox - Firefox started with no problems
4. Repeated the above for every add-on - Firefox started each time correctly
5. Repeated the above for every plugin - again, no problems.

This means that the default profile now works correctly.
Is this still an issue or can we close this report `?
Flags: needinfo?(msw)
(Reporter)

Comment 5

5 years ago
Report can be closed.
Flags: needinfo?(msw)
(Reporter)

Comment 6

5 years ago
Report can be closed.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.